Bug 137434 - Unable to remove logical and physical volume
Summary: Unable to remove logical and physical volume
Status: CLOSED DUPLICATE of bug 137099
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-28 14:29 UTC by Phil Knirsch
Modified: 2015-03-05 01:14 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 19:06:40 UTC


Attachments (Terms of Use)

Description Phil Knirsch 2004-10-28 14:29:30 UTC
Description of problem:

After setting up a simple physical and logical volume i tried to
remove the logical volume and then afterwards the physical one.

I added a physical volume alled A and then added a logical volume
called B.

In then managed to remove the logical volume B, but the logical view
for A still was there despite the fact that the logical volume B had
been removed.

When i now tried to remove either the logical view or the physical
volume a dialog with an error pops up.

If i try to remove the logical view the message is this:

lvremove command failed. Command attempted: "/usr/sbin/lvremove
--force Unused"

And when i try to remove the complete physical volume i don't get an
error but nothing happens. But when i try to remove the partition from
the physical volume A i get this error:

vgreduce command failed. Command attempted: "/usr/sbin/vgreduce A
/dev/hda2"

So all in call, i was only able to remove the logical volume B. I can
then add the logical volume B again and remove that, but the effect
stays the same.

If i invoke "lvm vgremove" from the commandline it works nicely and
when i then restart the tool i get a clean and unused partition
/dev/hda2 again.

Version-Release number of selected component (if applicable):

system-config-lvm-0.9.3-1.0

How reproducible:

Always

Steps to Reproduce:
1. Create physical and logical volumes
2. Remove logical volume
3. Try to remove logical view or physical volume
  
Actual results:

Removal doesn't work or error dialogs pop up.

Expected results:

Removal of logical and physical volumes should work without errors.

Additional info:

Comment 1 Jim Parsons 2004-11-10 03:57:42 UTC
This ticket describes two issues: 
1) The selection tree was not being updated after an item was deleted
2) PV remove was not giving proper diagnostic messages

Both have been addressed in 0.9.7-1.0

Comment 2 Derek Anderson 2004-11-11 20:13:29 UTC

*** This bug has been marked as a duplicate of 137099 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:06:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.