Bug 137438 - MySQL server timeout error on startup
MySQL server timeout error on startup
Status: CLOSED DUPLICATE of bug 142328
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mysql (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
: 137573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-28 10:43 EDT by thewolf
Modified: 2013-07-02 23:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thewolf 2004-10-28 10:43:56 EDT
Description of problem:
I installed the latest 'mysql-server' package, now when I try to start
the database server, I got the following error message:

---
Timeout error occurred trying to start MySQL Daemon.
Starting MySQL: [FAILED]
---

The MySQL server starts up and works fine anyway.

Version-Release number of selected component (if applicable):
mysql-server-3.23.58-2.3

How reproducible:
Always

Steps to Reproduce:
1. up2date mysql-server
2. service mysqld stop
3. service mysqld start

Expected Results:  Since the MySQL server starts up and works fine,
there should be no error message on screen.
Comment 1 Tom Lane 2004-10-28 10:57:39 EDT
Have you perhaps disabled anonymous users in MySQL?  If so, this is
expected behavior --- see the /etc/rc.d/init.d/mysqld script.  You can
tweak the script to use a valid username if you like.  I don't really
know of any better way to make the script test for server ready :-(
Comment 2 Tom Lane 2004-10-29 12:19:42 EDT
*** Bug 137573 has been marked as a duplicate of this bug. ***
Comment 3 Jim Faulkner 2004-11-01 11:25:15 EST
Modifying the /etc/rc.d/init.d/mysqld does not seem to be an
acceptable solution.  Doing that requires that either
a) I have a user who is allowed access without a password
or
b) I type the clear-text password for the user directly into the rc
script.

I'd prefer to do neither.  The old startup script seemed to work fine...
Comment 4 Tom Lane 2004-11-01 11:52:02 EST
The best solution I can think of is to create a user who has no
permissions to actually do anything; then whether you give it a
password or not hardly matters ...

It may be that MySQL 4.x has a better way to probe for
is-the-server-up-yet than this, but I don't know of one in 3.x.
Comment 5 Tom Lane 2004-12-08 21:02:29 EST
I'm planning to adopt the solution shown in bug #142328.

*** This bug has been marked as a duplicate of 142328 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:06:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.