Bug 137573 - MySQL does not start properly after installing mysql-server-3.23.58-2.3.i386.rpm
MySQL does not start properly after installing mysql-server-3.23.58-2.3.i386.rpm
Status: CLOSED DUPLICATE of bug 137438
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mysql (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 11:47 EDT by Jim Faulkner
Modified: 2013-07-02 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Faulkner 2004-10-29 11:47:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
After installing the latest mysql-server package available from the
RedHat Network Red Hat Enterprise Linux AS (v. 3 for x86) Extras
channel, MySQL does not start up properly anymore.

This is what happens when I attempt to start the mysql server:
--------------------------------------------------------------
/etc/init.d/mysqld start
Timeout error occurred trying to start MySQL Daemon.
Starting MySQL:                                            [FAILED]
--------------------------------------------------------------

Here is what is in my log file after trying the start the mysql server:
---------------------------------------------------------------
041028 11:45:48  mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
/usr/libexec/mysqld: ready for connections
A mysqld process already exists at  Thu Oct 28 11:46:04 EDT 2004
----------------------------------------------------------------

This has happened on two of my machines, both of which are fully
up-to-date.  Downgrading to mysql-server-3.23.58-1.i386.rpm solves the
problem, but it would be nice to have the latest version working.


Version-Release number of selected component (if applicable):
mysql-server-3.23.58-2.3

How reproducible:
Always

Steps to Reproduce:
1.upgrade to the latest version of mysql-server
2.attempt to start mysql server by running "/etc/init.d/mysqld start"
3.
    

Actual Results:  I received this error message:

Timeout error occurred trying to start MySQL Daemon.
Starting MySQL:                                            [FAILED]


Expected Results:  It should have started properly.


Additional info:
Comment 1 Tom Lane 2004-10-29 11:56:27 EDT
Does the server actually not start, or is this just a misleading log
message?  I suspect this report may be a duplicate of bug #137438.
Comment 2 Jim Faulkner 2004-10-29 12:03:22 EDT
Oops, you're right.  The server does actually start up properly, and
appears to work fine.
Comment 3 Tom Lane 2004-10-29 12:19:30 EDT
OK, I'm going to close this one as a dup then; feel free to comment on
the other entry.

*** This bug has been marked as a duplicate of 137438 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.