Bug 1375132 - Image username is ignored on GCE
Summary: Image username is ignored on GCE
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - GCE
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-12 08:52 UTC by Maxim Burgerhout
Modified: 2018-09-04 17:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:47:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22749 None None None 2018-03-02 10:07:17 UTC

Description Maxim Burgerhout 2016-09-12 08:52:24 UTC
Description of problem:
When creating an image (in this case on GCE), you can specify a username. Iiuc, this username is then used by Satellite to run the finish_template.

On GCE, this username is completely ignored, so when creating a new instance, the Fog default of 'root' is used to setup ssh public key authentication for. This fails, of course, because root would never be allowed to log in remotely on a cloud instance by default.

Version-Release number of selected component (if applicable):
6.2.1

How reproducible:


Steps to Reproduce:
1. Setup GCE compute resource (see bug 1374335)
2. Specify image and setup username
3. Try and create a new host

Actual results:
Running the finish_template fails, so new host is left unconfigured

Expected results:
Finish_template runs

Additional info:
Workaround is to override the default in line 20 of /opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.36.0/lib/fog/compute/models/server.rb, so I'm thinking the username is not passed to the Fog Google::Server class properly.

Comment 1 Maxim Burgerhout 2016-09-12 09:07:55 UTC
Just to make sure: what happens is that ssh key authentication is setup for the default user (i.e. root), but login from Satellite for running the finish_template is actually attempted with the username specified for the image.

Can provide screenshots if unclear.

Comment 3 Daniel Lobato Garcia 2018-03-02 10:07:14 UTC
Created redmine issue http://projects.theforeman.org/issues/22749 from this bug

Comment 4 Bryan Kearney 2018-09-04 17:47:36 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.