Bug 137557 - Fc3-RC2 crashes on upgrade of FC3-test3
Summary: Fc3-RC2 crashes on upgrade of FC3-test3
Status: CLOSED DUPLICATE of bug 137345
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-29 14:15 UTC by G.S. Link
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description G.S. Link 2004-10-29 14:15:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
File /usr/src/build/473461-i386/install/usr/lib/anaconda/gui.py line
789 in next clicked
self.dispatch.gotonext()
dispatch.py line 171 in gotonext self.moveStep()
dispatch.py line 239 in moveStep RC= apply(func,self.findargs(args))
upgrade.py line 715 in upgradeFindPackages
id.upgradeDeps("%s%s\n%(id.upgradeDeps,text))
Type error "str" object not callable

Anaconda quits on an upgrade from FC3-test3 to FC3-RC2 when it tries
to calculate the dependencies.  Dump is above.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade RH9 to FC3-test3 then install several of the additional
packages.  This must be done by manually installing the RPMs.
2.Upgrade the system to FC3-RC2
3.
    

Actual Results:  Second upgrade failed

Expected Results:  Should not have given a trace.

Additional info:

Comment 1 Jeremy Katz 2004-10-29 14:39:30 UTC

*** This bug has been marked as a duplicate of 137345 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:06:42 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.