Bug 137599 - /etc/X11/xinit/xinitrc-common: line 45: 4770 Segmentation fault (core dumped) xmodmap "$sysmodmap"
/etc/X11/xinit/xinitrc-common: line 45: 4770 Segmentation fault (core d...
Status: CLOSED DUPLICATE of bug 138458
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-29 14:56 EDT by Daniel Reed
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/Xmodmap (547 bytes, text/plain)
2004-10-29 14:56 EDT, Daniel Reed
no flags Details

  None (edit)
Description Daniel Reed 2004-10-29 14:56:31 EDT
[dreed@localhost ~]$ gdb xmodmap core.4770
GNU gdb Red Hat Linux (6.1post-1.20040607.41rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols
found)...Using host libthread_db library "/lib/tls/libthread_db.so.1".

Core was generated by `xmodmap /etc/X11/Xmodmap'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libX11.so.6...(no debugging symbols
found)...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /lib/tls/libc.so.6...Reading symbols from
/usr/lib/debug/lib/tls/libc-2.3.3.so.debug...done.
done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /lib/libdl.so.2...Reading symbols from
/usr/lib/debug/lib/libdl-2.3.3.so.debug...done.
done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/ld-linux.so.2...Reading symbols from
/usr/lib/debug/lib/ld-2.3.3.so.debug...done.
done.
Loaded symbols for /lib/ld-linux.so.2
#0  _int_malloc (av=0xf6fc3800, bytes=144169120) at malloc.c:3993
3993          fwd->bk = victim;
(gdb) bt
#0  _int_malloc (av=0xf6fc3800, bytes=144169120) at malloc.c:3993
#1  0xf6f021e1 in *__GI___libc_malloc (bytes=1) at malloc.c:3337
#2  0x08048fd1 in ?? ()
#3  0x00000001 in ?? ()
#4  0x00000001 in ?? ()
#5  0x00000000 in ?? ()
(gdb) 


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12
xinitrc-4.0.14-1

How reproducible:
Every time I startx
Comment 1 Daniel Reed 2004-10-29 14:56:31 EDT
Created attachment 105955 [details]
/etc/X11/Xmodmap
Comment 2 Sammy 2004-10-29 22:11:50 EDT
If you put a comment line into .Xmodmap file as: 
 
!Page Left 
 
NOTE no space between "!" and "Page" sourcing this segfaults every time. 
 
If you write 
 
! Page Left 
 
than everything sourcing works fine! 
 
FYI 
Comment 3 Henrique Martins 2004-11-18 18:56:23 EST
I don't think the space is important.  Any line with 11 characters
before the new line seems to do it, i.e.:
  !2345678901
will do it, but
  !234567890
or
  !23456789012
will not.

There may be other combinations that work.
Comment 4 Mike A. Harris 2005-02-16 17:12:48 EST

*** This bug has been marked as a duplicate of 138458 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:06:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.