Bug 138458 - (xmodmap-segv) xmodmap SEGV - glibc detected free(): invalid pointer
xmodmap SEGV - glibc detected free(): invalid pointer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 137599 138743 139102 139205 139259 139469 140224 141503 148038 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 08:46 EST by John Ellson
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 02:47:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2004-11-09 08:46:59 EST
Description of problem:
Console message during startx:
*** glibc detected *** free(): invalid pointer: 0x0982f7c8 ***
/etc/X11/xinit/xinitrc-common: line 45: 13273 Aborted                
xmodmap "$sysmodmap"


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12
glibc-2.3.3-75

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2004-11-09 08:57:46 EST
Problem is reproducible.  Occurs on first startx after reboot.

May be related to the x11 error that just preceeded the glibc message:
(EE) I810(0): [agp] Unable to allocate system texture memory.
Disabling DRI.
Comment 2 John Ellson 2004-11-09 08:59:12 EST
Possibly related to Bug #132267 ?
Comment 3 Toni Willberg 2004-11-13 13:51:57 EST
I can reproduce this problem with fresh FC3 installation without any
configuration changes.

 xorg-x11-6.8.1-12
 glibc-2.3.3-74
 xinitrc-4.0.14-1

I installed FC3 to my test laptop without Gnome, just with XFce
desktop. Initlevel set to the default 5.

After installation my (non-root, didn't test with root) user can't log
in using GDM's "1. Default System Session" session.

After login, a dialog pops up, and closing the dialog logs the user
out. Dialog's text:

/etc/X11/gdm/PreSession/Default: Registering your session with wtmp
and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
/var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0"
"twillber"
*** glibc detected *** free(): invalid pointer: 0x08d507c8 ***
/etc/X11/xinit/xinitrc-common: line 45: 28853 Aborted                
xmodmap "$sysmodmap"
Agent pid 28864

Comment 4 Toni Willberg 2004-11-13 13:54:46 EST
I forgot to mention that selecting "2.Xfce Session" works, and user
can log in to his desktop without problems.

The "Default System Session" should equal to "Xfce Session" as there
are no other desktops installed.

Comment 5 Mike A. Harris 2004-11-16 20:59:28 EST
*** Bug 139259 has been marked as a duplicate of this bug. ***
Comment 6 Mike A. Harris 2004-11-16 20:59:37 EST
*** Bug 139469 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2004-11-16 21:02:28 EST
This bug is fixed in internal CVS, and in rawhide.  An update
will be released in the near future with a fix for this problem.

Setting status to "RAWHIDE" for now.
Comment 8 Need Real Name 2004-11-17 03:10:10 EST
Great. Any chance of getting a version number for the future fix, or
an update when this is an officially available update?
Comment 9 Mike A. Harris 2004-11-17 21:12:11 EST
Users who would like to be informed of Fedora Core software
updates can subscribe to the fedora-announce-list@redhat.com, which
is where we post update announcements as they're made available.
The version number of the updates are present in the announcements
posted to that list.  The email archives are also publically
available for people to peruse if they'd like to see announcments
made prior to their subscription to the list.

Hope this helps.
Comment 10 Mike A. Harris 2004-11-17 21:22:27 EST
*** Bug 138743 has been marked as a duplicate of this bug. ***
Comment 11 Mike A. Harris 2004-11-17 21:24:13 EST
Bug #138743 which I just closed as a dupe, was the original bug
that Kristian got when he fixed the issue.  Here is the comment
Kristian replied to this issue when he fixed it, so the fix
seems to be in 6.8.1-13 and later:



 Additional Comment #1 From Kristian Høgsberg (krh@redhat.com)  on
2004-11-11 10:45 -------
Private Comment

Yikes, good catch, nice bug report, thanks.  I've applied your
suggested bug fix to our RPM, will be available in 6.8.1-13.

cheers,
Kristian

Comment 12 Mike A. Harris 2004-11-17 21:24:44 EST
*** Bug 139102 has been marked as a duplicate of this bug. ***
Comment 13 Mike A. Harris 2004-11-17 21:26:39 EST
*** Bug 139205 has been marked as a duplicate of this bug. ***
Comment 14 Mike A. Harris 2004-11-22 15:53:34 EST
*** Bug 140224 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2004-11-22 19:54:54 EST
This bug is fixed in rawhide, however, just as a note to everyone
experiencing this issue, we thought the fix also got into
our recent security update, but it turns out due to a minor
glitch, the patch got left out.

Since some people are asking, we do consider this problem
serious, and it will definitely be fixed when we do the next
cumulative xorg-x11 update for Fedora Core, which will likely
happen sometime between now and mid-January depending on various
factors.  In the mean time, you should be able to use the
rawhide xorg-x11 to work around this problem.

This bug was previously closed as "RAWHIDE" since it was fixed
first in our development tree, however since there are a lot of
people experiencing the problem, I'm going to reopen this bug for
the time being, until we release an updated xorg-x11 for FC3 with
the fix, in hopes users querying bugzilla will find the problem
has already been reported multiple times to us.

We apologize for any inconveniences due to this glitch, and will
update this bug report once new official rpms are ready for testing
for Fedora Core 3.

Thanks to everyone for reporting the issue to us.
Comment 16 Need Real Name 2004-11-23 02:59:38 EST
> suggested bug fix to our RPM, will be available in 6.8.1-13

Two months? :/

6.8.1-13 doesn't seem to be on any part of the ftp site - any chance
of a url?
Comment 17 Mike A. Harris 2004-11-23 04:49:33 EST
> Two months? :/

Actually, I said "which will likely happen sometime between now
and mid-January depending on various factors.".  Reason being
that I find when I say "will be fixed in a future update" I often
get a request back from the reporter asking for the specific
date or date range in which we'll be releasing an update to fix
the problem, however non-security related Fedora updates do not
have explicit dates attached to them for which we will be
releasing erratum on.  It's easier to say "will be fixed in
the next random undisclosed amount of time" or "next few months"
than to give a specific date that may come and go without an
update being released.

There are a number of issues in FC3's xorg-x11 which we have
either fixed already or do plan on having fixes for in the
near future, but without any specific timeline.  Since it
is much easier to fix many of them all at once compared to
shipping a new release for each bugfix, we generally will wait
until a number of important bugfixes (in our eyes) have been
fixed in order to make going through the process of an update
more economically viable use of our manpower resources.
Developer workloads and various other things may also factor
into the time that passes until we release an update, so it
is almost impossible to say "this will be fixed by <date>"
without lying to people half the time.

Since saying "we have no idea" is equally not useful to people,
I try to make a realistic guestimate of a future date in which
I think there is a good likelyhood that we'll have released an
update which fixes the issue for people, which seems in practice
to be a reasonably good balance that is realistic.  The alternative
would be making promises that turn out to often be false, or
making honest misjudgements about dates we honestly do not have
enough information with which to formulate.

The real answer, which I find people think sucks, is "no specific
date until it is ready and released", which I've learned over time
makes people more upset than just not giving an answer.  ;o)  As
such, I try to find a balance between telling people something,
and not being unrealistic at the same time.  X.Org X11 6.8.2
may be released in early January, and I'd like to ship that
as an update, so that seems a good time to do it.  ;o)

Hope this helps understand timelines better.  If it only confuses
things though, the much shorter answer (which people hate) is
"when it's ready"  ;o)

>6.8.1-13 doesn't seem to be on any part of the ftp site - any chance
>of a url?

Sorry, I don't use our public ftp servers because I find they're
too slow unless using a mirror, in which case the URL varies by
site, and I have to manually search for what I'm looking for
myself anyway.  ;o)  The short answer is to just get whatever
is the current xorg-x11 in rawhide a.k.a "Fedora devel" that
is newer than what shipped in Fedora Core 3 and use that.  If
there isn't one, just wait until rawhide gets updated publically
with the newer bits and you should be good to go.

Hope this helps.  ;o)
Comment 18 Need Real Name 2004-11-26 15:51:36 EST
Yep! Thanks a lot.

The new package (xorg-x11-6.8.1-19) works, but prelink must be run
(for me) first.
Comment 19 Mike A. Harris 2004-12-07 02:45:51 EST
*** Bug 141503 has been marked as a duplicate of this bug. ***
Comment 20 Mike A. Harris 2004-12-07 02:47:22 EST
This problem is resolved in the latest official
update of xorg-x11-6.8.1-12.FC3.21 for Fedora Core 3.

Setting status to "ERRATA"
Comment 21 Mike A. Harris 2005-02-16 17:12:04 EST
*** Bug 148038 has been marked as a duplicate of this bug. ***
Comment 22 Mike A. Harris 2005-02-16 17:13:08 EST
*** Bug 137599 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.