Bug 1376331 - Rpm installation fails with conflicts error for eventsconfig.json file
Summary: Rpm installation fails with conflicts error for eventsconfig.json file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: 3.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On: 1375532
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-15 06:23 UTC by Aravinda VK
Modified: 2016-12-06 05:59 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1375532
Environment:
Last Closed: 2016-12-06 05:59:47 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-09-15 06:23:20 UTC
+++ This bug was initially created as a clone of Bug #1375532 +++

Description of problem:
Rpm installation fails with below error

Error: Transaction check error:
      file /etc/glusterfs/eventsconfig.json conflicts between attempted installs of glusterfs-events-3.10dev-0.51.gitc9271ff.fc24.x86_64 and glusterfs-server-3.10dev-0.51.gitc9271ff.fc24.x86_64

--- Additional comment from Worker Ant on 2016-09-13 06:45:45 EDT ---

REVIEW: http://review.gluster.org/15486 (eventsapi/packaging: Fix conflict during rpm install) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Worker Ant on 2016-09-14 03:29:32 EDT ---

REVIEW: http://review.gluster.org/15486 (eventsapi/packaging: Fix conflict during rpm install) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Worker Ant on 2016-09-14 23:04:33 EDT ---

COMMIT: http://review.gluster.org/15486 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 656873c4c8f5f3b05823c51f20c2a44106662550
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Sep 13 15:38:24 2016 +0530

    eventsapi/packaging: Fix conflict during rpm install
    
    RPM installation fails with following error
    
      Error: Transaction check error:
        file /etc/glusterfs/eventsconfig.json conflicts between attempted
        installs of glusterfs-events-3.10dev-0.51.gitc9271ff.fc24.x86_64
        and glusterfs-server-3.10dev-0.51.gitc9271ff.fc24.x86_64
    
    Changed attributes of eventsconfig.json file as same as other
    config files and excluded this file in server rpm.
    
    BUG: 1375532
    Change-Id: I3708c8fc58448cd5a6ebe611250f10e0658bdd58
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15486
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2016-09-15 06:24:32 UTC
REVIEW: http://review.gluster.org/15502 (eventsapi/packaging: Fix conflict during rpm install) posted (#1) for review on release-3.9 by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-09-15 11:31:30 UTC
COMMIT: http://review.gluster.org/15502 committed in release-3.9 by Aravinda VK (avishwan@redhat.com) 
------
commit aea936562540d15a6c4708ec9ef050136de483b3
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Sep 13 15:38:24 2016 +0530

    eventsapi/packaging: Fix conflict during rpm install
    
    RPM installation fails with following error
    
      Error: Transaction check error:
        file /etc/glusterfs/eventsconfig.json conflicts between attempted
        installs of glusterfs-events-3.10dev-0.51.gitc9271ff.fc24.x86_64
        and glusterfs-server-3.10dev-0.51.gitc9271ff.fc24.x86_64
    
    Changed attributes of eventsconfig.json file as same as other
    config files and excluded this file in server rpm.
    
    > Reviewed-on: http://review.gluster.org/15486
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    
    BUG: 1376331
    Change-Id: I3708c8fc58448cd5a6ebe611250f10e0658bdd58
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    (cherry picked from commit 656873c4c8f5f3b05823c51f20c2a44106662550)
    Reviewed-on: http://review.gluster.org/15502
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Milind Changire <mchangir@redhat.com>

Comment 3 Aravinda VK 2016-10-27 05:23:01 UTC
glusterfs-3.9.0rc2 is released[1] and packages are available for different distributions[2] to test.

[1] http://www.gluster.org/pipermail/maintainers/2016-October/001601.html
[2] http://www.gluster.org/pipermail/maintainers/2016-October/001605.html and http://www.gluster.org/pipermail/maintainers/2016-October/001606.html

Comment 4 Aravinda VK 2016-12-06 05:59:47 UTC
Gluster 3.9 GA is released http://blog.gluster.org/2016/11/announcing-gluster-3-9/


Note You need to log in before you can comment on or make changes to this bug.