Bug 1375532 - Rpm installation fails with conflicts error for eventsconfig.json file
Summary: Rpm installation fails with conflicts error for eventsconfig.json file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: eventsapi
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Aravinda VK
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1351589 1376331
TreeView+ depends on / blocked
 
Reported: 2016-09-13 10:40 UTC by Aravinda VK
Modified: 2017-03-06 17:26 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376331 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:26:11 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Aravinda VK 2016-09-13 10:40:13 UTC
Description of problem:
Rpm installation fails with below error

Error: Transaction check error:
      file /etc/glusterfs/eventsconfig.json conflicts between attempted installs of glusterfs-events-3.10dev-0.51.gitc9271ff.fc24.x86_64 and glusterfs-server-3.10dev-0.51.gitc9271ff.fc24.x86_64

Comment 1 Worker Ant 2016-09-13 10:45:45 UTC
REVIEW: http://review.gluster.org/15486 (eventsapi/packaging: Fix conflict during rpm install) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 2 Worker Ant 2016-09-14 07:29:32 UTC
REVIEW: http://review.gluster.org/15486 (eventsapi/packaging: Fix conflict during rpm install) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 3 Worker Ant 2016-09-15 03:04:33 UTC
COMMIT: http://review.gluster.org/15486 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 656873c4c8f5f3b05823c51f20c2a44106662550
Author: Aravinda VK <avishwan@redhat.com>
Date:   Tue Sep 13 15:38:24 2016 +0530

    eventsapi/packaging: Fix conflict during rpm install
    
    RPM installation fails with following error
    
      Error: Transaction check error:
        file /etc/glusterfs/eventsconfig.json conflicts between attempted
        installs of glusterfs-events-3.10dev-0.51.gitc9271ff.fc24.x86_64
        and glusterfs-server-3.10dev-0.51.gitc9271ff.fc24.x86_64
    
    Changed attributes of eventsconfig.json file as same as other
    config files and excluded this file in server rpm.
    
    BUG: 1375532
    Change-Id: I3708c8fc58448cd5a6ebe611250f10e0658bdd58
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/15486
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-03-06 17:26:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.