Bug 1376805 - disperse: Integrate important events with events framework
Summary: disperse: Integrate important events with events framework
Keywords:
Status: CLOSED DUPLICATE of bug 1361084
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: disperse
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ashish Pandey
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On: 1371470
Blocks: 1361084 1374167
TreeView+ depends on / blocked
 
Reported: 2016-09-16 12:35 UTC by Ashish Pandey
Modified: 2016-09-17 04:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1371470
Environment:
Last Closed: 2016-09-16 12:48:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ashish Pandey 2016-09-16 12:35:49 UTC
+++ This bug was initially created as a clone of Bug #1371470 +++

Description of problem:

Add following events for EC translator

1- EVENT_EC_DATA_BRICKS_NOT_UP -
   When atlest "K" number of bricks, required
   for any ec fop, are not up.
2- EVENT_EC_DATA_BRICKS_UP
   When atlest "K" number of bricks, required
   for any ec fop, are up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2016-08-30 06:07:41 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-08-30 06:08:31 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-08-31 02:01:47 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-08-31 04:22:02 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-08-31 08:29:01 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)

--- Additional comment from Worker Ant on 2016-09-06 18:31:38 EDT ---

REVIEW: http://review.gluster.org/15348 (cluster/ec: Add events for EC translator) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

--- Additional comment from Worker Ant on 2016-09-07 12:10:15 EDT ---

COMMIT: http://review.gluster.org/15348 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit e1584b1c1df656612f6233ac40ba55f29591b0c3
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Tue Aug 30 14:17:58 2016 +0530

    cluster/ec: Add events for EC translator
    
    This patch will generates events in following
    cases which will be consumed by new event
    framework.
    
    Consider an EC volume with (K+M) configuration
    K = Data bricks
    M = Redundancy bricks
    
    1- EVENT_EC_MIN_BRICKS_NOT_UP -
       When minimum "K" number of bricks, required
       for any ec fop, are not up.
    2- EVENT_EC_MIN_BRICKS_UP
       When minimum "K" number of bricks, required
       for any ec fop, are up.
    
    Change-Id: I0414b8968c39740a171e5aa14b087afd524d574f
    BUG: 1371470
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/15348
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 2 Atin Mukherjee 2016-09-16 18:15:03 UTC
Ashish - This BZ should be closed with a duplicate bug id, not with "not a bug" which makes a wrong sense. Please change it accordingly.

Comment 3 Ashish Pandey 2016-09-17 04:41:01 UTC

*** This bug has been marked as a duplicate of bug 1361084 ***


Note You need to log in before you can comment on or make changes to this bug.