Bug 137696 - xorg D600 (ATI 9000) ACPI unsuspend broken (+patches)
Summary: xorg D600 (ATI 9000) ACPI unsuspend broken (+patches)
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-30 20:23 UTC by Vladimir Vukicevic
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 14:29:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg-bugzilla_fdo_1220_radeon_swsusp.patch (791 bytes, patch)
2004-10-30 20:24 UTC, Vladimir Vukicevic
no flags Details | Diff
xorg-079_ati_radeon_fix_power_resume.diff (1.47 KB, patch)
2004-10-30 20:25 UTC, Vladimir Vukicevic
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 1220 None None None Never

Description Vladimir Vukicevic 2004-10-30 20:23:28 UTC
With kernel 2.6.8-1.541, and xorg 6.8.1-4, the dell D600 does not come
back from ACPI suspend correctly; the X server comes back to either
garbage or to a blank white screen.  The attached two patches, the
first one from freedesktop.org bug 1220, the second from the debian
xf86 dist, fix this; ACPI suspend and unsuspend work fine with X with
these two patches applied and the xorg package rebuilt.

The D600 suspend script I use is:

#!/bin/bash
rmmod snd_intel8x0m
rmmod snd_intel8x0
rmmod snd_ac97_codec
rmmod ehci_hcd
echo 3 >/proc/acpi/sleep
modprobe ehci_hcd
modprobe snd_intel8x0 snd_intel8x0m

Comment 1 Vladimir Vukicevic 2004-10-30 20:24:29 UTC
Created attachment 105982 [details]
xorg-bugzilla_fdo_1220_radeon_swsusp.patch

Patch from fd.o bug 1220

Comment 2 Vladimir Vukicevic 2004-10-30 20:25:06 UTC
Created attachment 105983 [details]
xorg-079_ati_radeon_fix_power_resume.diff

Patch from debian xserver-xfree86 package

Comment 3 Mike A. Harris 2004-11-29 14:24:03 UTC
Please file a bug report in X.Org bugzilla located at
http://bugs.freedesktop.org in the 'xorg' component, and attach
these patches for review and consideration by X.Org developers
into the next X.Org release.

Once the patches have been reviewed by X.Org, if they are accepted,
they will be integrated into the CVS trunk and appear in a future
X.Org release, which will also eventually end up in a future
Fedora Core release.

Once you've filed your submission to X.Org, please paste the bug
report URL here, and we will track it also.

Thanks in advance.

Comment 4 Mike A. Harris 2004-11-29 14:29:39 UTC
I seem to have overlooked the bug number in comment #1 above,
perhaps due to incorrect URL.  I see this was already committed
to the CVS head and stable branch upstream.

As such, it will automatically be integrated into Fedora Core
when we upgrade to 6.8.2 in a month or so.  As such, I'm going to
close this bug as "NEXTRELEASE" to indicate our first official
6.8.2 rpms released in the future.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.