Bug 1377448 - glusterd: Display proper error message and fail the command if S32gluster_enable_shared_storage.sh hook script is not present during gluster volume set all cluster.enable-shared-storage <enable/disable> command
Summary: glusterd: Display proper error message and fail the command if S32gluster_ena...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.8
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1388348 1389168 1389197
TreeView+ depends on / blocked
 
Reported: 2016-09-19 17:41 UTC by Jay Flory
Modified: 2016-11-29 09:36 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1388348 1389168 (view as bug list)
Environment:
Last Closed: 2016-11-29 09:36:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Jay Flory 2016-09-19 17:41:54 UTC
Description of problem:


Version-Release number of selected component (if applicable): GlusterFS 3.8.4 (latest)

How reproducible: Always


Steps to Reproduce:
1. Run command: "gluster volume set all cluster.enable-shared-storage enable"

Actual results:
1. The running Volume now lists "cluster.enable-shared-storage: enable"
a. The command returned success.
2. However the shared volume was not created.

Expected results:
1. When the command fails, a failure return code is expected.
a. With a relevant description.
2. It is expected that the command will create the shared volume.

Additional info:

OS: Debian Jessie

1. Rebooting did not help.
2. Rebuilding the clustered data volume did not help.
3. Clearing files in /var/run/gluster did not help. 
4. Logs lack error messages except:
   readv on /var/run/gluster/d373e2b2e599fb58e944558312eb1ae5.socket failed (Invalid argument)

Comment 1 Avra Sengupta 2016-10-21 09:57:32 UTC
Was the hook script /var/lib/glusterd/hooks/1/set/post/S32gluster_enable_shared_storage.sh present at the time this was seen. Hook scripts get deleted when we clean up /var/lib/glusterd, and need to be installed again.

Comment 2 Jay Flory 2016-10-23 15:38:06 UTC
1. At this point I am not able to tell if it was installed.
a. I have long since moved on and installed by other means.
2. Where is this documented about the scripts?
3. If the scripts are missing but needed, the command should fail and specifically state that the scripts are missing.
a. The command should not fail but report success.

Comment 3 Avra Sengupta 2016-10-24 08:55:18 UTC
I agree, maybe we can edit the summary of this bug to reflect the same, and make the necessary changes so that the command fails with the appropriate message.

Comment 4 Avra Sengupta 2016-10-25 06:46:39 UTC
Based on comment #3, updating the summary of the bug.

Comment 5 Worker Ant 2016-10-27 07:33:04 UTC
REVIEW: http://review.gluster.org/15741 (glusterd/shared storage: Check for hook-script at staging) posted (#1) for review on release-3.8 by Avra Sengupta (asengupt@redhat.com)

Comment 6 Worker Ant 2016-11-07 05:18:31 UTC
COMMIT: http://review.gluster.org/15741 committed in release-3.8 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 42e334eef6f64663bababe30bb6faf8bd00e6bc9
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Tue Oct 25 12:44:29 2016 +0530

    glusterd/shared storage: Check for hook-script at staging
    
    Check if S32gluster_enable_shared_storage.sh is present
    at /var/lib/glusterd/hooks/1/set/post/ at staging
    before proceeding with the command. Fail the command
    with the appropriate error message in case it is not
    present.
    
    > Reviewed-on: http://review.gluster.org/15718
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    (cherry picked from commit 29587a91716e1e55bd172d63340c40249fb343c9)
    
    Change-Id: I84e3912f1cdffb927f8a40d74d52be43ee69388b
    BUG: 1377448
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/15741
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 7 Niels de Vos 2016-11-29 09:36:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.6, please open a new bug report.

glusterfs-3.8.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2016-November/000217.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.