Bug 137777 - printconf-backend in non English locale
Summary: printconf-backend in non English locale
Status: CLOSED DUPLICATE of bug 131563
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-01 08:06 UTC by Andrew Martynov
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:06:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Martynov 2004-11-01 08:06:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7)
Gecko/20040616

Description of problem:
If system configured for Russian language as system language in
/etc/sysconfig/i18n then /usr/sbin/printconf-backend fail with python
traceback and cups service also could not start correctly.

I found that it happens in function "which_spooler" of module
"cups_impour.py". Binary file "alternatives" display localized output
messages while looks for English message.

Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.47.3.19-1

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 3 ES
2. Setup system language "Russian", for example by editing file
/etc/sysconfig/i18n:
LANG="ru_RU.UTF-8"
SUPPORTED="ru_RU.UTF-8:ru_RU:ru"
SYSFONT="latarcyrheb-sun16"
3. reboot system or execute in bash 'export LANG=ru_RU.UTF-8'
4. execute /usr/sbin/printconf-backend
5. restart cups : service cups restart
    

Actual Results:  /usr/sbin/printconf-backend does not produce lines
Cups is restarted correctly

Expected Results:  /usr/sbin/printconf-backend is failed with python
traceback and message about unbound variable 'which' in module
/usr/share/printconf/util/cups_import.py

Additional info:

cups_import.py module execute /usr/sbin/alternatives in current locate
but wait output message in English.

Comment 1 Andrew Martynov 2004-11-01 09:21:48 UTC
I found temporary solution to return cups back to English locale.

Add in the beginning of /etc/init.d/cups file two lines:
LANG=C
NOLOCALE=yes

So printconf-backend executed in C locale and work correctly.

Comment 2 Tim Waugh 2004-11-01 09:24:57 UTC

*** This bug has been marked as a duplicate of 131563 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:06:44 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.