Bug 1377816 - Wi-Fi and Bluetooth with 4.7.x kernel do not work any longer
Summary: Wi-Fi and Bluetooth with 4.7.x kernel do not work any longer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1410987 (view as bug list)
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2016-09-20 16:30 UTC by billiboy
Modified: 2017-02-27 22:49 UTC (History)
10 users (show)

Fixed In Version: kernel-4.9.11-200.fc25 kernel-4.9.12-100.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-27 22:49:21 UTC


Attachments (Terms of Use)

Description billiboy 2016-09-20 16:30:26 UTC
Description of problem:

Wi-Fi and Bluetooth with 4.7.x kernel do not work any longer

Version-Release number of selected component (if applicable):

kernel 4.7.x or later

How reproducible:

Always with kernel 4.7.x or later

Steps to Reproduce:

Use kernel 4.7.x or later on device with Wi-Fi/Bluetooth hardware attached via mmc SDIO (e.g. cubox-i, hummingboard)

Actual results:

Kernel is booting without mmc SDIO support where the Wi-Fi and Bluetooth hardware is attached

Expected results:

Kernel is booting with mmc SDIO support so Wi-Fi and Bluetooth attached hardware can be used as with pre 4.7.x kernels

Additional info:

Since kernel 4.7.x Wi-Fi and Bluetooth is no longer working for my cubox-i out of the box.
Fedora is building the arm kernels with "# CONFIG_PWRSEQ_SIMPLE is not set", rebuilding with "CONFIG_PWRSEQ_SIMPLE=y" make it work for me again.
Since I build the mmc support as buil-in,  "CONFIG_PWRSEQ_SIMPLE=m" should be sufficient.

Comment 1 Peter Robinson 2017-02-15 23:20:15 UTC
Apologies, this has slipped through the cracks, this is now enabled (along with PWRSEQ_EMMC) on all branches. It will appear in the next kernel build (sadly we just missed 4.9.10-200.fc25).

Comment 2 Peter Robinson 2017-02-15 23:56:01 UTC
*** Bug 1410987 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2017-02-22 15:09:21 UTC
kernel-4.9.11-200.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-14e693580c

Comment 4 Fedora Update System 2017-02-22 15:10:30 UTC
kernel-4.9.11-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f53be9dcde

Comment 5 Fedora Update System 2017-02-23 22:22:36 UTC
kernel-4.9.11-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f53be9dcde

Comment 6 Fedora Update System 2017-02-23 23:20:45 UTC
kernel-4.9.11-200.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-14e693580c

Comment 7 Fedora Update System 2017-02-24 15:24:56 UTC
kernel-4.9.12-100.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b9f61c68d

Comment 8 Fedora Update System 2017-02-24 22:50:28 UTC
kernel-4.9.11-200.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-02-25 00:54:07 UTC
kernel-4.9.12-100.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4b9f61c68d

Comment 10 Fedora Update System 2017-02-27 22:49:21 UTC
kernel-4.9.12-100.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.