Bug 1377973 - ipa-server-install fails when the provided or resolved IP address is not found on local interfaces
Summary: ipa-server-install fails when the provided or resolved IP address is not foun...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
Depends On:
Blocks: 1460663
TreeView+ depends on / blocked
 
Reported: 2016-09-21 08:12 UTC by Jan Pazdziora
Modified: 2017-08-01 09:39 UTC (History)
8 users (show)

Fixed In Version: ipa-4.5.0-19.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1460663 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:39:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Jan Pazdziora 2016-09-21 08:12:07 UTC
Description of problem:

With RHEL 7.2 content, IdM in container started fine even if the hostname of the container did not resolve to any IP address in the container.

With RHEL 7.3 nightly, that no longer seems possible.

Version-Release number of selected component (if applicable):

ipa-server-4.4.0-12.el7.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Run docker run with IPA server in container based on https://github.com/adelton/docker-freeipa with hostname matching the hostname of the host, like -h machine1.domain1.company.com and ipa-server-install-options containing

-U
--ds-password='The-directory-server-password'
--admin-password='The-admin-password'
--realm=REALM.TEST
--domain=example.test
--setup-dns
--forwarder=10.11.12.13

Actual results:

systemd 219 running in system mode. (+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 -SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
Detected virtualization docker.
Detected architecture x86-64.
Set hostname to <machine1.domain1.company.com>.
Wed Sep 21 01:51:50 EDT 2016 /usr/sbin/ipa-server-configure-first 
Checking DNS domain example.test, please wait ...

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

Warning: skipping DNS resolution of host machine1.domain1.company.com
Checking DNS domain example.test., please wait ...
No usable IP address provided nor resolved.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information
FreeIPA server configuration failed.

The ipaserver-install.log ends with

2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.rename_managed
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_ca_topology
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_idranges
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_managed_permissions
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_nis
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_pacs
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_passsync
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_referint
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_services
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.update_uniqueness
2016-09-21T05:51:53Z DEBUG importing plugin module ipaserver.install.plugins.upload_cacrt
2016-09-21T05:51:54Z DEBUG Loading Index file from '/var/lib/ipa/sysrestore/sysrestore.index'
2016-09-21T05:51:54Z INFO Checking DNS domain example.test., please wait ...
2016-09-21T05:51:54Z DEBUG Name machine1.domain1.company.com. resolved to set([UnsafeIPAddress('10.11.50.60')])
2016-09-21T05:51:54Z WARNING Invalid IP address 10.11.50.60 for machine1.domain1.company.com: no network interface matches the IP address and netmask 10.11.50.60
2016-09-21T05:51:54Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 171, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipapython/install/cli.py", line 318, in run
    cfgr.run()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 308, in run
    self.validate()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 317, in validate
    for nothing in self._validator():
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 372, in __runner
    self._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 362, in __runner
    step()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 359, in <lambda>
    step = lambda: next(self.__gen)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
    value = gen.send(prev_value)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 564, in _configure
    next(validator)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 372, in __runner
    self._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 449, in _handle_exception
    self.__parent._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 446, in _handle_exception
    super(ComponentBase, self)._handle_exception(exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 394, in _handle_exception
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 362, in __runner
    step()
  File "/usr/lib/python2.7/site-packages/ipapython/install/core.py", line 359, in <lambda>
    step = lambda: next(self.__gen)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 81, in run_generator_with_yield_from
    six.reraise(*exc_info)
  File "/usr/lib/python2.7/site-packages/ipapython/install/util.py", line 59, in run_generator_with_yield_from
    value = gen.send(prev_value)
  File "/usr/lib/python2.7/site-packages/ipapython/install/common.py", line 63, in _install
    for nothing in self._installer(self.parent):
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 1355, in main
    install_check(self)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 267, in decorated
    func(installer)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/install.py", line 603, in install_check
    dns.install_check(False, api, False, options, host_name)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/dns.py", line 260, in install_check
    True, options.ip_addresses)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 536, in get_server_ip_address
    sys.exit(1)

2016-09-21T05:51:54Z DEBUG The ipa-server-install command failed, exception: SystemExit: 1
2016-09-21T05:51:54Z ERROR The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Expected results:

With RHEL 7.2 compose, the output is

systemd 219 running in system mode. (+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 -SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
Detected virtualization docker.
Detected architecture x86-64.
Set hostname to <machine1.domain1.company.com>.
Initializing machine ID from random generator.
Wed Sep 21 01:52:19 EDT 2016 /usr/sbin/ipa-server-configure-first 

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Wait for the container to configure the server
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::


The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

Warning: skipping DNS resolution of host machine1.domain1.company.com
Checking DNS forwarders, please wait ...
Using reverse zone(s) 0.17.172.in-addr.arpa.

The IPA Master Server will be configured with:
Hostname:       machine1.domain1.company.com
IP address(es): 172.17.0.2
Domain name:    example.test
Realm name:     REALM.TEST

BIND DNS server will be configured to serve IPA domain with:
Forwarders:    10.11.12.13
Reverse zone(s):  0.17.172.in-addr.arpa.

[...]

and the matching piece in ipaserver-install.log was

2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.rename_managed
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_idranges
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_managed_permissions
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_nis
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_pacs
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_passsync
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_referint
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_services
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.update_uniqueness
2016-09-21T05:52:20Z DEBUG importing plugin module ipaserver.install.plugins.upload_cacrt
2016-09-21T05:52:20Z DEBUG SessionAuthManager.register: name=jsonserver_session_73923536
2016-09-21T05:52:20Z DEBUG SessionAuthManager.register: name=xmlserver_session_73942352
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.xmlserver_session() at '/session/xml'
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.xmlserver() at '/xml'
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.jsonserver_kerb() at '/json'
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.change_password() at '/session/change_password'
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.login_kerberos() at '/session/login_kerberos'
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:20Z DEBUG Mounting ipaserver.rpcserver.login_password() at '/session/login_password'
2016-09-21T05:52:20Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:21Z DEBUG Mounting ipaserver.rpcserver.jsonserver_session() at '/session/json'
2016-09-21T05:52:21Z DEBUG session_auth_duration: 0:20:00
2016-09-21T05:52:21Z DEBUG Mounting ipaserver.rpcserver.sync_token() at '/session/sync_token'
2016-09-21T05:52:21Z DEBUG Loading Index file from '/var/lib/ipa/sysrestore/sysrestore.index'
2016-09-21T05:52:21Z DEBUG Starting external process
2016-09-21T05:52:21Z DEBUG args='/sbin/ip' '-family' 'inet' '-oneline' 'address' 'show'
2016-09-21T05:52:21Z DEBUG Process finished, return code=0
2016-09-21T05:52:21Z DEBUG stdout=1: lo    inet 127.0.0.1/8 scope host lo\       valid_lft forever preferred_lft forever
48: eth0    inet 172.17.0.2/16 scope global eth0\       valid_lft forever preferred_lft forever

2016-09-21T05:52:21Z DEBUG stderr=
2016-09-21T05:52:21Z DEBUG Checking DNS server: 10.11.12.13
2016-09-21T05:52:21Z DEBUG will use dns_forwarders: [CheckedIPAddress('10.11.12.13')]

2016-09-21T05:52:21Z DEBUG Backing up system configuration file '/etc/hosts'
2016-09-21T05:52:21Z DEBUG Saving Index File to '/var/lib/ipa/sysrestore/sysrestore.index'
2016-09-21T05:52:21Z DEBUG group dirsrv exists
2016-09-21T05:52:21Z DEBUG user dirsrv exists

Additional info:

Even when I add --no-host-dns to the ipa-server-install-options, I get

systemd 219 running in system mode. (+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ -LZ4 -SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
Detected virtualization docker.
Detected architecture x86-64.
Set hostname to <machine1.domain1.company.com>.
Wed Sep 21 03:59:19 EDT 2016 /usr/sbin/ipa-server-configure-first 
Checking DNS domain example.test, please wait ...

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

Warning: skipping DNS resolution of host machine1.domain1.company.com
Checking DNS domain example.test., please wait ...
No usable IP address provided nor resolved.
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information
FreeIPA server configuration failed.

Comment 3 Jan Pazdziora 2016-09-21 08:27:41 UTC
(In reply to Jan Pazdziora from comment #1)
> 
> Fix is potentially in:
> 
> https://fedorahosted.org/freeipa/ticket/4317

Pasted wrong link -- fix is potentially in:

https://fedorahosted.org/freeipa/ticket/5814

Comment 4 Martin Bašti 🖰 2016-09-21 08:36:52 UTC
I'd say that this is more bugfix of missing validation in 7.2 and not regression in 7.3. AFAIK is intended for all installers to check if local address match resolved addresses (at least without DNS installation) to prevent IP misconfiguration on local or DNS side

Ticket #5814 allows to use network/broadcast addresses, but there is still need to ip-address on a local interface


Related tickets for this: #4317, #2715

Comment 5 Jan Pazdziora 2016-09-21 08:37:53 UTC
Seeing get_server_ip_address has special check for ['127.0.0.1', '::1'], I've also tried to use --ip-address=127.0.0.2 to force local address yet one which is not in the list but that fails with

ipa-server-install: error: option --ip-address: invalid IP address 127.0.0.2: cannot use loopback IP address 127.0.0.2

Comment 6 Martin Bašti 🖰 2016-09-21 08:40:09 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4317

Comment 7 Martin Bašti 🖰 2016-09-21 08:40:16 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2715

Comment 8 Jan Pazdziora 2016-09-21 08:51:36 UTC
Quick workaround:

diff --git a/ipaserver/install/installutils.py b/ipaserver/install/installutils.py
index 7578bf8..211f6f2 100644
--- a/ipaserver/install/installutils.py
+++ b/ipaserver/install/installutils.py
@@ -508,7 +508,7 @@ def get_server_ip_address(host_name, unattended, setup_dns, ip_addresses):
     if len(hostaddr):
         for ha in hostaddr:
             try:
-                ips.append(ipautil.CheckedIPAddress(ha, match_local=True))
+                ips.append(ipautil.CheckedIPAddress(ha, match_local=False))
             except ValueError as e:
                 root_logger.warning("Invalid IP address %s for %s: %s", ha, host_name, unicode(e))

Comment 9 Martin Bašti 🖰 2016-09-21 09:43:46 UTC
(In reply to Jan Pazdziora from comment #5)
> Seeing get_server_ip_address has special check for ['127.0.0.1', '::1'],
> I've also tried to use --ip-address=127.0.0.2 to force local address yet one
> which is not in the list but that fails with
> 
> ipa-server-install: error: option --ip-address: invalid IP address
> 127.0.0.2: cannot use loopback IP address 127.0.0.2

There is ticket for loopback addresses to be allowed in --forwarder option
https://fedorahosted.org/freeipa/ticket/5801

However I don't see reason why loopback addresses should be allowed as address of IPA server.

Comment 10 Jan Pazdziora 2016-09-21 09:52:00 UTC
Perhaps because in certain environments like in containers, the loopback addresses are the only thing that you can reliably assume to be available with certain value before starting the environment.

Since IPA is now able to update its own IP address in the DNS post-installation, why does the installer even care that loopback IP address is used during installation? Especially when specified explicitly by the admin, not merely autodiscovered by the installer.

Comment 11 Martin Bašti 🖰 2016-09-21 09:55:06 UTC
Ok, I don't know what can breaks in IPA using loopback address, please file a separate ticket to allow usage of loopback address.

Comment 12 Jan Pazdziora 2016-09-21 09:56:03 UTC
Ideally, the check in installer which tries to figure out if the IP address is IPA server's IP address, wouldn't try to look at its network interfaces but would instead (or in addition) try to use that IP address (make request on port 443 or similar) and check that it is routed back to the IPA server. That would cover both the NAT use cases of AWS and the port exposure of containers.

Comment 13 Jan Pazdziora 2016-09-21 09:57:04 UTC
(In reply to Martin Bašti from comment #11)
> Ok, I don't know what can breaks in IPA using loopback address, please file
> a separate ticket to allow usage of loopback address.

For me the use of loopback addresses is not essential -- I've merely showed is as an example of approaches that I've tried as workaround.

Comment 30 Nikhil Dehadrai 2017-06-14 08:20:08 UTC
Besed on above observations in comment#28 and comment#29, changing the status of bug to "ASSIGNED"

Comment 35 Nikhil Dehadrai 2017-06-23 16:21:56 UTC
ipa-server: ipa-server-4.5.0-19.el7.x86_64

Verified the bug on the basis of following observations:
1. Verified that IPA-server installation is successful and no Warning messages are displayed when there is valid/correct IP address is associated with network interface and also host name is correctly resolvable.
2. Verified that no such warning message is displayed during replica-installation as well.

Console:
------------- 
[root@auto-hv-01-guest06 ~]# hostname
auto-hv-01-guest06.testrelm.test
[root@auto-hv-01-guest06 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:13:e7:2d brd ff:ff:ff:ff:ff:ff
    inet 10.x.x.x/23 brd 10.19.35.255 scope global dynamic eth0
       valid_lft 85931sec preferred_lft 85931sec
    inet6 2620:52:0:1322:5054:ff:fe13:e72d/64 scope global noprefixroute dynamic
       valid_lft 2591811sec preferred_lft 604611sec
    inet6 fe80::5054:ff:fe13:e72d/64 scope link
       valid_lft forever preferred_lft forever
[root@auto-hv-01-guest06 ~]# rpm -q ipa-server
ipa-server-4.5.0-19.el7.x86_64
[root@auto-hv-01-guest06 ~]# ipa-server-install
 
The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.
 
This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure the KDC to enable PKINIT
 
To accept the default shown in brackets, press the Enter key.
 
WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd
 
Do you want to configure integrated DNS (BIND)? [no]: yes
 
Enter the fully qualified domain name of the computer
on which you're setting up server software. Using the form
<hostname>.<domainname>
Example: master.example.com.
 
 
Server host name [auto-hv-01-guest06.testrelm.test]:
 
Warning: skipping DNS resolution of host auto-hv-01-guest06.testrelm.test
The domain name has been determined based on the host name.
 
Please confirm the domain name [testrelm.test]:
 
The kerberos protocol requires a Realm name to be defined.
This is typically the domain name converted to uppercase.
 
Please provide a realm name [TESTRELM.TEST]:
Certain directory server operations require an administrative user.
This user is referred to as the Directory Manager and has full access
to the Directory for system management tasks and will be added to the
instance of directory server created for IPA.
The password must be at least 8 characters long.
 
Directory Manager password:
Password (confirm):
 
The IPA server requires an administrative user, named 'admin'.
This user is a regular system account used for IPA server administration.
 
IPA admin password:
Password (confirm):
 
Checking DNS domain testrelm.test., please wait ...
Do you want to configure DNS forwarders? [yes]:
Following DNS servers are configured in /etc/resolv.conf: 10.x.x.x
Do you want to configure these servers as DNS forwarders? [yes]:
All DNS servers from /etc/resolv.conf were added. You can enter additional addresses now:
Enter an IP address for a DNS forwarder, or press Enter to skip: 10.x.x.x
DNS forwarder 10.x.x.x added. You may add another.
Enter an IP address for a DNS forwarder, or press Enter to skip:
Checking DNS forwarders, please wait ...
Do you want to search for missing reverse zones? [yes]:
 
The IPA Master Server will be configured with:
Hostname:       auto-hv-01-guest06.testrelm.test
IP address(es): 10.x.x.x
Domain name:    testrelm.test
Realm name:     TESTRELM.TEST
 
BIND DNS server will be configured to serve IPA domain with:
Forwarders:       10.x.x.x, 10.x.x.x
Forward policy:   only
Reverse zone(s):  No reverse zone
 
Continue to configure the system with these values? [no]: yes
 
The following operations may take some minutes to complete.
Please wait until the prompt is returned.
 
Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 30 seconds
  [1/45]: creating directory server instance
  [2/45]: enabling ldapi
  [3/45]: configure autobind for root
  [4/45]: stopping directory server
  [5/45]: updating configuration in dse.ldif
  [6/45]: starting directory server
  [7/45]: adding default schema
  [8/45]: enabling memberof plugin
  [9/45]: enabling winsync plugin
  [10/45]: configuring replication version plugin
  [11/45]: enabling IPA enrollment plugin
  [12/45]: configuring uniqueness plugin
  [13/45]: configuring uuid plugin
  [14/45]: configuring modrdn plugin
  [15/45]: configuring DNS plugin
  [16/45]: enabling entryUSN plugin
  [17/45]: configuring lockout plugin
  [18/45]: configuring topology plugin
  [19/45]: creating indices
  [20/45]: enabling referential integrity plugin
  [21/45]: configuring certmap.conf
  [22/45]: configure new location for managed entries
  [23/45]: configure dirsrv ccache
  [24/45]: enabling SASL mapping fallback
  [25/45]: restarting directory server
  [26/45]: adding sasl mappings to the directory
  [27/45]: adding default layout
  [28/45]: adding delegation layout
  [29/45]: creating container for managed entries
  [30/45]: configuring user private groups
  [31/45]: configuring netgroups from hostgroups
  [32/45]: creating default Sudo bind user
  [33/45]: creating default Auto Member layout
  [34/45]: adding range check plugin
  [35/45]: creating default HBAC rule allow_all
  [36/45]: adding entries for topology management
  [37/45]: initializing group membership
  [38/45]: adding master entry
  [39/45]: initializing domain level
  [40/45]: configuring Posix uid/gid generation
  [41/45]: adding replication acis
  [42/45]: activating sidgen plugin
  [43/45]: activating extdom plugin
  [44/45]: tuning directory server
  [45/45]: configuring directory to start on boot
Done configuring directory server (dirsrv).
Configuring Kerberos KDC (krb5kdc)
  [1/10]: adding kerberos container to the directory
  [2/10]: configuring KDC
  [3/10]: initialize kerberos container
  [4/10]: adding default ACIs
  [5/10]: creating a keytab for the directory
  [6/10]: creating a keytab for the machine
  [7/10]: adding the password extension to the directory
  [8/10]: creating anonymous principal
  [9/10]: starting the KDC
  [10/10]: configuring KDC to start on boot
Done configuring Kerberos KDC (krb5kdc).
Configuring kadmin
  [1/2]: starting kadmin
  [2/2]: configuring kadmin to start on boot
Done configuring kadmin.
Configuring certificate server (pki-tomcatd). Estimated time: 3 minutes
  [1/29]: configuring certificate server instance
  [2/29]: exporting Dogtag certificate store pin
  [3/29]: stopping certificate server instance to update CS.cfg
  [4/29]: backing up CS.cfg
  [5/29]: disabling nonces
  [6/29]: set up CRL publishing
  [7/29]: enable PKIX certificate path discovery and validation
  [8/29]: starting certificate server instance
  [9/29]: configure certmonger for renewals
  [10/29]: requesting RA certificate from CA
  [11/29]: setting up signing cert profile
  [12/29]: setting audit signing renewal to 2 years
  [13/29]: restarting certificate server
  [14/29]: publishing the CA certificate
  [15/29]: adding RA agent as a trusted user
  [16/29]: authorizing RA to modify profiles
  [17/29]: authorizing RA to manage lightweight CAs
  [18/29]: Ensure lightweight CAs container exists
  [19/29]: configure certificate renewals
  [20/29]: configure Server-Cert certificate renewal
  [21/29]: Configure HTTP to proxy connections
  [22/29]: restarting certificate server
  [23/29]: updating IPA configuration
  [24/29]: enabling CA instance
  [25/29]: migrating certificate profiles to LDAP
  [26/29]: importing IPA certificate profiles
  [27/29]: adding default CA ACL
  [28/29]: adding 'ipa' CA entry
  [29/29]: configuring certmonger renewal for lightweight CAs
Done configuring certificate server (pki-tomcatd).
Configuring directory server (dirsrv)
  [1/3]: configuring TLS for DS instance
  [2/3]: adding CA certificate entry
  [3/3]: restarting directory server
Done configuring directory server (dirsrv).
Configuring ipa-otpd
  [1/2]: starting ipa-otpd
  [2/2]: configuring ipa-otpd to start on boot
Done configuring ipa-otpd.
Configuring ipa-custodia
  [1/5]: Generating ipa-custodia config file
  [2/5]: Making sure custodia container exists
  [3/5]: Generating ipa-custodia keys
  [4/5]: starting ipa-custodia
  [5/5]: configuring ipa-custodia to start on boot
Done configuring ipa-custodia.
Configuring the web interface (httpd)
  [1/22]: stopping httpd
  [2/22]: setting mod_nss port to 443
  [3/22]: setting mod_nss cipher suite
  [4/22]: setting mod_nss protocol list to TLSv1.0 - TLSv1.2
  [5/22]: setting mod_nss password file
  [6/22]: enabling mod_nss renegotiate
  [7/22]: disabling mod_nss OCSP
  [8/22]: adding URL rewriting rules
  [9/22]: configuring httpd
  [10/22]: setting up httpd keytab
  [11/22]: configuring Gssproxy
  [12/22]: setting up ssl
  [13/22]: configure certmonger for renewals
  [14/22]: importing CA certificates from LDAP
  [15/22]: publish CA cert
  [16/22]: clean up any existing httpd ccaches
  [17/22]: configuring SELinux for httpd
  [18/22]: create KDC proxy config
  [19/22]: enable KDC proxy
  [20/22]: starting httpd
  [21/22]: configuring httpd to start on boot
  [22/22]: enabling oddjobd
Done configuring the web interface (httpd).
Configuring Kerberos KDC (krb5kdc)
  [1/1]: installing X509 Certificate for PKINIT
Done configuring Kerberos KDC (krb5kdc).
Applying LDAP updates
Upgrading IPA:. Estimated time: 1 minute 30 seconds
  [1/9]: stopping directory server
  [2/9]: saving configuration
  [3/9]: disabling listeners
  [4/9]: enabling DS global lock
  [5/9]: starting directory server
  [6/9]: upgrading server
  [7/9]: stopping directory server
  [8/9]: restoring configuration
  [9/9]: starting directory server
Done.
Restarting the KDC
Configuring DNS (named)
  [1/11]: generating rndc key file
  [2/11]: adding DNS container
  [3/11]: setting up our zone
  [4/11]: setting up our own record
  [5/11]: setting up records for other masters
  [6/11]: adding NS record to the zones
  [7/11]: setting up kerberos principal
  [8/11]: setting up named.conf
  [9/11]: setting up server configuration
  [10/11]: configuring named to start on boot
  [11/11]: changing resolv.conf to point to ourselves
Done configuring DNS (named).
Restarting the web server to pick up resolv.conf changes
Configuring DNS key synchronization service (ipa-dnskeysyncd)
  [1/7]: checking status
  [2/7]: setting up bind-dyndb-ldap working directory
  [3/7]: setting up kerberos principal
  [4/7]: setting up SoftHSM
  [5/7]: adding DNSSEC containers
  [6/7]: creating replica keys
  [7/7]: configuring ipa-dnskeysyncd to start on boot
Done configuring DNS key synchronization service (ipa-dnskeysyncd).
Restarting ipa-dnskeysyncd
Restarting named
Updating DNS system records
Configuring client side components
Using existing certificate '/etc/ipa/ca.crt'.
Client hostname: auto-hv-01-guest06.testrelm.test
Realm: TESTRELM.TEST
DNS Domain: testrelm.test
IPA Server: auto-hv-01-guest06.testrelm.test
BaseDN: dc=testrelm,dc=test
 
Skipping synchronizing time with NTP server.
New SSSD config will be created
Configured sudoers in /etc/nsswitch.conf
Configured /etc/sssd/sssd.conf
trying https://auto-hv-01-guest06.testrelm.test/ipa/json
[try 1]: Forwarding 'schema' to json server 'https://auto-hv-01-guest06.testrelm.test/ipa/json'
trying https://auto-hv-01-guest06.testrelm.test/ipa/session/json
[try 1]: Forwarding 'ping' to json server 'https://auto-hv-01-guest06.testrelm.test/ipa/session/json'
[try 1]: Forwarding 'ca_is_enabled' to json server 'https://auto-hv-01-guest06.testrelm.test/ipa/session/json'
Systemwide CA database updated.
Adding SSH public key from /etc/ssh/ssh_host_rsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ecdsa_key.pub
Adding SSH public key from /etc/ssh/ssh_host_ed25519_key.pub
[try 1]: Forwarding 'host_mod' to json server 'https://auto-hv-01-guest06.testrelm.test/ipa/session/json'
SSSD enabled
Configured /etc/openldap/ldap.conf
Configured /etc/ssh/ssh_config
Configured /etc/ssh/sshd_config
Configuring testrelm.test as NIS domain.
Client configuration complete.
The ipa-client-install command was successful
 
==============================================================================
Setup complete
 
Next steps:
        1. You must make sure these network ports are open:
                TCP Ports:
                  * 80, 443: HTTP/HTTPS
                  * 389, 636: LDAP/LDAPS
                  * 88, 464: kerberos
                  * 53: bind
                UDP Ports:
                  * 88, 464: kerberos
                  * 53: bind
                  * 123: ntp
 
        2. You can now obtain a kerberos ticket using the command: 'kinit admin'
           This ticket will allow you to use the IPA tools (e.g., ipa user-add)
           and the web user interface.
 
Be sure to back up the CA certificates stored in /root/cacert.p12
These files are required to create replicas. The password for these
files is the Directory Manager password
[root@auto-hv-01-guest06 ~]#

Thus on the basis of above observations, marking status of bug to "VERIFIED".

Comment 37 errata-xmlrpc 2017-08-01 09:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.