Bug 1460663 - ipa-server-install fails when the provided or resolved IP address is not found on local interfaces
ipa-server-install fails when the provided or resolved IP address is not foun...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa-server-docker (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Babinsky
Nikhil Dehadrai
: Extras, Regression
Depends On: 1377973
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 07:12 EDT by Martin Babinsky
Modified: 2017-08-01 09:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: ipa-server-docker-4.5.0-4
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1377973
Environment:
Last Closed: 2017-08-01 09:20:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Ellen Newlands 2017-06-26 12:07:56 EDT
Based on Business Need.  Remains a 7.4 blocker
Comment 9 Nikhil Dehadrai 2017-07-19 05:28:05 EDT
-bash-4.2# atomic host status
State: idle
Deployments:
● atomic-host:rhel-atomic-host/7/x86_64/standard
                Version: 7.4.0 (2017-07-13 17:46:26)
                 Commit: c28cad0d4144d91a3c206574e9341cd5bdf7d34cfaa2acb74dd84c0bf022593a

IPA-docker-image: ipa-server-docker-4.5.0-6
IPA-server-version: ipa-server-4.5.0-20.el7.x86_64

Verified the bug on the basis of following observations:
1. Verified that IPA-server installation is successful using ipa-docker image and no Warning messages are displayed when there is valid/correct IP address is associated with network interface and also host name is correctly resolvable.
2. Verified that no such warning message is displayed during replica-installation as well.
3. Verified that when unresolvable hostname or non-existent ip address on interface is used for installation, then appropriate warning is displayed and installation is successful.

Thus on the basis of above observations, marking status of bug to "VERIFIED".
Comment 11 errata-xmlrpc 2017-08-01 09:20:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2373

Note You need to log in before you can comment on or make changes to this bug.