Bug 13790 - Search munges search keywords
Search munges search keywords
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: WideOpen (Show other bugs)
current
All Linux
high Severity medium
: ---
: ---
Assigned To: Randy J. Ray
Paul Lindner
:
: 13791 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-12 10:19 EDT by Steve Coile
Modified: 2007-03-26 23:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 13:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Coile 2000-07-12 10:19:08 EDT
Search form inserts spaces into keywords, rendering searches invalid. 
Under conditions I can't quite pin-down, the search feature on the public
site will separate the last character of a keyword from the remainder of
the word by a space, rendering the term meaningless.  This appears to
happen only when multiple keywords are supplied.  For instance, try
performing a search for "ibm suse".  Note that the results reflect a search
for "ib m sus e".
Comment 1 Paul Lindner 2000-07-17 13:31:41 EDT
Looks like a bug in Text::Balanced, test case:

perl -MText::Balanced -e '$s = ("ibm suse" =~ /^(.*)/)[0]; @words =
Text::Balanced::extract_multiple($s); print join(",",@words)' ;

outputs:

ib,m sus,e

ugh....
Comment 2 Paul Lindner 2000-07-17 13:32:51 EDT
*** Bug 13791 has been marked as a duplicate of this bug. ***
Comment 3 Randy J. Ray 2000-08-04 21:47:03 EDT
This is fixed.

Note You need to log in before you can comment on or make changes to this bug.