Bug 1379269 - Wrong unit name output with "service" command
Summary: Wrong unit name output with "service" command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Leos Pol
URL:
Whiteboard:
Depends On: 1392766
Blocks: 1380361 1393867 1400961
TreeView+ depends on / blocked
 
Reported: 2016-09-26 09:08 UTC by Leos Pol
Modified: 2017-08-01 07:29 UTC (History)
2 users (show)

Fixed In Version: initscripts-9.49.38-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 07:29:01 UTC


Attachments (Terms of Use)
patch (1.00 KB, patch)
2016-09-26 10:05 UTC, Leos Pol
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2286 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2017-08-01 11:26:43 UTC
Red Hat Bugzilla 1258478 None None None Never

Internal Links: 1258478

Description Leos Pol 2016-09-26 09:08:17 UTC
Description of problem:
Command service something.socket restart produces well-known message "Redirecting...", but with "something.socket.service".
Also this bug affects other unit types (see Additional info).

Bug has been introduces in 
https://git.fedorahosted.org/cgit/initscripts.git/commit/?h=rhel7-branch&id=c7d25db27dbab853c4ccda8c984d84a7ceaf881d

Version-Release number of selected component (if applicable):
initscripts-9.49.37-1.el7

How reproducible:
Always

Steps to Reproduce:
1. service systemd-journald.socket restart

Actual results:
Redirecting to /bin/systemctl restart  systemd-journald.socket.service

Expected results:
Redirecting to /bin/systemctl restart  systemd-journald.socket

Additional info:
# service systemd-journald.service restart
Redirecting to /bin/systemctl restart  systemd-journald.service.service
# service mnt-qa.mount restart
Redirecting to /bin/systemctl restart  mnt-qa.mount.service

Comment 1 Leos Pol 2016-09-26 10:05:02 UTC
Created attachment 1204771 [details]
patch

Comment 6 Leos Pol 2017-04-26 12:20:01 UTC
# rpm -q initscripts
initscripts-9.49.37-1.el7.x86_64

# service systemd-journald.socket restart
Redirecting to /bin/systemctl restart  systemd-journald.socket.service

# rpm -q initscripts
initscripts-9.49.38-1.el7.x86_64

# service systemd-journald.socket restart
Redirecting to /bin/systemctl restart systemd-journald.socket

Comment 8 errata-xmlrpc 2017-08-01 07:29:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286


Note You need to log in before you can comment on or make changes to this bug.