Bug 1379741 - [RFE] Integrate HA Pacemaker managed services with director composable roles.
Summary: [RFE] Integrate HA Pacemaker managed services with director composable roles.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-pacemaker
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks: 1264181 1426483
TreeView+ depends on / blocked
 
Reported: 2016-09-27 14:41 UTC by Rob Young
Modified: 2017-09-15 03:08 UTC (History)
19 users (show)

Fixed In Version: puppet-pacemaker-0.5.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Previously, all pacemaker services had to be part of the same role. With this update, a new feature allows you to use composable roles with Pacemaker managed services. This feature is needed in order to scale out pacemaker managed services on more and different nodes.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:33:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Rob Young 2016-09-27 14:41:03 UTC
Description of problem:

Pacemaker managed services should be integrated with director composable roles. The current Controller PCMK and Contoller systemd roles should be retained. New roles should be added for the following HA components so they can be deployed, upgraded and scaled independently:

RabbitMQ - required
Galera - required
HAProxy - optional, but nice to have.
Separating the remaining Pacemaker managed services is optional.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Michele Baldessari 2017-01-27 07:50:03 UTC
Work upstream has merged. The patch series leading to this is here:
https://review.openstack.org/#/q/topic:bp/composable-ha

Comment 7 errata-xmlrpc 2017-05-17 19:33:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.