Bug 1379855 - Rebase: Upgrade ECJ to at least 4.4
Summary: Rebase: Upgrade ECJ to at least 4.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ecj
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Elliott Baron
QA Contact: Lukáš Zachar
Vladimír Slávik
URL:
Whiteboard:
Depends On: 1336481
Blocks: 1298243 1390370
TreeView+ depends on / blocked
 
Reported: 2016-09-27 21:23 UTC by Elliott Baron
Modified: 2017-08-01 16:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_ecj_ rebased to version 4.5.2 The _ecj_ package has been upgraded to upstream version 4.5.2, which provides a number of bug fixes and enhancements over the previous version. Notably, support for features added to the Java language in version 8 has been completed. As a result, compilation of Java code using Java 8 features no longer fails. This includes cases where code not using Java 8 features referenced code using these features, such as system classes provided by the Java Runtime Environment.
Clone Of: 1336481
Environment:
Last Closed: 2017-08-01 16:19:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1888 normal SHIPPED_LIVE ecj bug fix update 2017-08-01 17:54:27 UTC

Description Elliott Baron 2016-09-27 21:23:17 UTC
While RHEL 7 contains a newer ECJ release than RHEL 6, it is still older than 4.4. Thus it does not have full compatibility with Java 8. While Tomcat on RHEL 7 does not exhibit the behaviour seen in bug #1223609, it is possible that similar issues will arise in RHEL 7 due to future JDK 8 updates.

+++ This bug was initially created as a clone of Bug #1336481 +++

With the latest update to java-1.8.0-openjdk (java-1.8.0-openjdk-headless-1.8.0.91-0.b14.el6_7.x86_64) all JSP compilation for tomcat6 is broken. The workaround for the problem is to revert the java update to a previously stable release.

The reason for the problem is that ECJ's JDTCompiler classes have some sort of incompatibility with the OpenJDK update's java.io.ObjectInputStream class. This compatibility issue is causing an exception and preventing JSPs from compiling on tomcat6. See attached bug (https://bugzilla.redhat.com/show_bug.cgi?id=1223609#c13) for more details on this.

Is it possible to rebase ECJ to at least 4.4 to correct this?

Comment 8 errata-xmlrpc 2017-08-01 16:19:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1888


Note You need to log in before you can comment on or make changes to this bug.