Bug 138005 - libGLU.so is not available in 32bit form
libGLU.so is not available in 32bit form
Status: CLOSED DUPLICATE of bug 119095
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-03 14:24 EST by Shannon Petry
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Petry 2004-11-03 14:24:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
There is NO 32bit library "libGLU.so".  

(identical to bug ID 119095 which is closed).

Upon investigation, here is what is found.

# ls -l /usr/X11R6/lib/libGLU*
-rw-r--r--    1 root     root       673038 Sep 15 05:59
/usr/X11R6/lib/libGLU.a
lrwxrwxrwx    1 root     root           13 Nov  3 11:02
/usr/X11R6/lib/libGLU.so.1 -> libGLU.so.1.3
lrwxrwxrwx    1 root     root           30 Oct 26 16:47
/usr/X11R6/lib/libGLU.so.1.3 -> /usr/X11R6/lib64/libGLU.so.1.3

# file /usr/X11R6/lib64/libGLU.so.1.3
/usr/X11R6/lib64/libGLU.so.1.3: ELF 64-bit LSB shared object, AMD
x86-64, version 1 (SYSV), stripped

I read the report for bug 119095, which was closed and should not have
been.  There should be an update which puts the missing library into
it's proper place and corrects the links in the 32bit directory that
should be pointing to a 32bit library.

If there is a site to download an updated version of RH WS AMD64, or
an RPM which would fix this problem, please point me to the site.  I
used new install media received 3 weeks ago from Sun Microsystems, so
assume this to be current. 

I installed the OS 2 times to ensure I did not do as the support tech
mentioned in bug 119095 and "rpm --force" install a different version.
 All that ran was RH install, and up2date on this system.

It is critical for 99% of my applications to have the 32bit library
installed.



Version-Release number of selected component (if applicable):
libGLU.so.1.3 (XFree86-Mesa-libGLU-4.3.0-35.EL)

How reproducible:
Always

Steps to Reproduce:
1.  Install AMD64 RH workstation from media
2.  ls -l /usr/X11R6/lib/libGLU*
3.  You will not find a 32bit version of libGLU on the system.
    

Actual Results:  As it was explained, no 32bit library for "libGLU.so"
is found on the OS.  locate shows libGLU in 2 locations
(/usr/X11R6/lib, and /usr/X11R6/lib64).  the /usr/X11R6/lib/libGLU.so
is a symbolic link to /usr/X11R6/lib64.

Expected Results:  I should have a 32bit library in the 32bit library
directory, and 64bit library in the 64bit library.

Additional info:

While priority is set to normal, if Redhat would like additional
licenses of AS and WS to be sold my customer must have working
versions of AMD64 Linux.  As it is now, openGL based applications will
not function in the AMD64 version of Redhat.
Comment 1 Mike A. Harris 2004-11-16 00:53:33 EST

*** This bug has been marked as a duplicate of 119095 ***
Comment 2 Shannon Petry 2004-11-16 08:31:28 EST
This problem is resolved by downloading and installing the 1386
Mesa-LibGLU*.rpm file matching the version installed for AMD_64.

The 32bit version should be installed by default, and needs to be
packaged in the AMD_64 distribution to resolve this issue.

Engineering Applications running OpenGL will not run currently in
64bit OpenGL, but will run in 32bit.  This includes ProE, MSC Patran,
Altair Hypermesh, and many many more.

Remember that the trees being build by most major vendors are not only
for *nix/Linux which can do 64bit, but Windows which can only do 32bit
(and even does a poor job at 32bit).

Vendors are not yet building 64bit graphic trees.
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.