Bug 119095 - libGLU.so.1 missing on AMD64 RHEL3
libGLU.so.1 missing on AMD64 RHEL3
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mesa (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Jay Turner
:
: 119097 138005 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 17:31 EST by Mark Langsdorf
Modified: 2015-01-07 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-30 17:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Langsdorf 2004-03-24 17:31:47 EST
Description of problem:
This version of redhat does not install a 32 bit version of the 
library "libGLU.so.1" in /usr/X11R6/lib.  It puts links to it 
in /usr/lib but does not install the actual library.

Version-Release number of selected component (if applicable):


How reproducible:
ls -l /usr/X11R6/lib/libGLU.so.1


Actual results:
file not found

Expected results:
a listing of the file

Additional info:
Comment 1 Mike A. Harris 2004-03-24 17:53:06 EST
Please indicate the specific name-version-release of all XFree86
packages installed on the system by doing:

rpm -q --qf '%{name}-%{version}-%{release}.%{arch}\n' \
     $(rpm -qa | grep "^XFree86" ) | sort

Also, please do the following:

uname -a
rpm -qf /usr/lib/libGLU.so.1
rpm -qf /usr/X11R6/lib/libGLU.so.1
ls -al /usr/lib/libGLU*
ls -al /usr/X11R6/lib/libGLU*

Comment 2 Mark Langsdorf 2004-03-24 18:10:40 EST
XFree86-100dpi-fonts-4.3.0-35.EL.x86_64
XFree86-100dpi-fonts-4.3.0-62.EL.x86_64
XFree86-4.3.0-35.EL.x86_64
XFree86-4.3.0-62.EL.x86_64
XFree86-75dpi-fonts-4.3.0-35.EL.x86_64
XFree86-75dpi-fonts-4.3.0-62.EL.x86_64
XFree86-base-fonts-4.3.0-35.EL.x86_64
XFree86-base-fonts-4.3.0-62.EL.x86_64
XFree86-devel-4.3.0-35.EL.i386
XFree86-doc-4.3.0-35.EL.x86_64
XFree86-doc-4.3.0-62.EL.x86_64
XFree86-font-utils-4.3.0-35.EL.x86_64
XFree86-font-utils-4.3.0-62.EL.x86_64
XFree86-libs-4.3.0-35.EL.i386
XFree86-libs-4.3.0-35.EL.i386
XFree86-libs-4.3.0-35.EL.x86_64
XFree86-libs-4.3.0-35.EL.x86_64
XFree86-libs-4.3.0-62.EL.i386
XFree86-libs-4.3.0-62.EL.i386
XFree86-libs-4.3.0-62.EL.x86_64
XFree86-libs-4.3.0-62.EL.x86_64
XFree86-libs-data-4.3.0-35.EL.x86_64
XFree86-libs-data-4.3.0-62.EL.x86_64
XFree86-Mesa-libGL-4.3.0-35.EL.i386
XFree86-Mesa-libGL-4.3.0-35.EL.i386
XFree86-Mesa-libGL-4.3.0-35.EL.x86_64
XFree86-Mesa-libGL-4.3.0-35.EL.x86_64
XFree86-Mesa-libGL-4.3.0-62.EL.i386
XFree86-Mesa-libGL-4.3.0-62.EL.i386
XFree86-Mesa-libGL-4.3.0-62.EL.x86_64
XFree86-Mesa-libGL-4.3.0-62.EL.x86_64
XFree86-Mesa-libGLU-4.3.0-35.EL.x86_64
XFree86-Mesa-libGLU-4.3.0-62.EL.i386
XFree86-Mesa-libGLU-4.3.0-62.EL.i386
XFree86-Mesa-libGLU-4.3.0-62.EL.x86_64
XFree86-Mesa-libGLU-4.3.0-62.EL.x86_64
XFree86-tools-4.3.0-35.EL.x86_64
XFree86-tools-4.3.0-62.EL.x86_64
XFree86-truetype-fonts-4.3.0-35.EL.x86_64
XFree86-truetype-fonts-4.3.0-62.EL.x86_64
XFree86-twm-4.3.0-35.EL.x86_64
XFree86-twm-4.3.0-62.EL.x86_64
XFree86-xauth-4.3.0-35.EL.x86_64
XFree86-xauth-4.3.0-62.EL.x86_64
XFree86-xdm-4.3.0-35.EL.x86_64
XFree86-xdm-4.3.0-62.EL.x86_64
XFree86-xfs-4.3.0-35.EL.x86_64
XFree86-xfs-4.3.0-62.EL.x86_64
XFree86-Xnest-4.3.0-35.EL.x86_64
XFree86-Xnest-4.3.0-62.EL.x86_64
XFree86-Xvfb-4.3.0-35.EL.x86_64
XFree86-Xvfb-4.3.0-62.EL.x86_64
Linux smpnow.amd.com 2.4.21-11.ELsmp #1 SMP Mon Mar 8 23:16:38 EST 
2004 x86_64 x86_64 x86_64 GNU/Linux
XFree86-Mesa-libGLU-4.3.0-62.EL
XFree86-Mesa-libGLU-4.3.0-62.EL
lrwxrwxrwx    1 root     root           33 Nov 17 
13:36 /usr/lib/libGLU.so -> ../../usr/X11R6/lib/libGLU.so.1.3
lrwxrwxrwx    1 root     root           33 Mar 24 
14:40 /usr/lib/libGLU.so.1 -> ../../usr/X11R6/lib/libGLU.so.1.3
-rw-r--r--    1 root     root       673710 Oct  3 
05:13 /usr/X11R6/lib/libGLU.a
lrwxrwxrwx    1 root     root           13 Nov 17 
13:36 /usr/X11R6/lib/libGLU.so -> libGLU.so.1.3
lrwxrwxrwx    1 root     root           13 Mar 24 
14:40 /usr/X11R6/lib/libGLU.so.1 -> libGLU.so.1.3
-rwxr-xr-x    1 root     root       503384 Mar  4 
22:10 /usr/X11R6/lib/libGLU.so.1.3

It looks like it was still a bug in RHEL3 Update 1, but got fixed in
RHEL3 Update 2 Beta1.  Thanks!
Comment 3 Mike A. Harris 2004-03-25 13:15:34 EST
You seem to have force installed multiple copies of the same
package several times somehow, rather than upgrading them, or your
RPM database is corrupted:

XFree86-Mesa-libGL-4.3.0-35.EL.i386
XFree86-Mesa-libGL-4.3.0-35.EL.i386

XFree86-Mesa-libGL-4.3.0-35.EL.x86_64
XFree86-Mesa-libGL-4.3.0-35.EL.x86_64

XFree86-Mesa-libGL-4.3.0-62.EL.i386
XFree86-Mesa-libGL-4.3.0-62.EL.i386

XFree86-Mesa-libGL-4.3.0-62.EL.x86_64
XFree86-Mesa-libGL-4.3.0-62.EL.x86_64

XFree86-Mesa-libGLU-4.3.0-62.EL.i386
XFree86-Mesa-libGLU-4.3.0-62.EL.i386

XFree86-Mesa-libGLU-4.3.0-35.EL.x86_64
XFree86-Mesa-libGLU-4.3.0-62.EL.x86_64
XFree86-Mesa-libGLU-4.3.0-62.EL.x86_64

Have you used the --force or --nodeps to upgrade these packages?
If so, that is probably the cause of corruption.

That would not break the libGLU symlink however, as the symlinks
are not created at installtime or runtime, but rather at build
time.  I have checked the libGLU symlinks in all of the above 32bit
and 64bit library packages, and our supplied symlinks are pointing
to the proper location on all of our released 32bit and 64bit
libGLU and libGL packages.

I'm not sure how your symlinks got pointing to the wrong place,
but I do not believe anything in our packaging could cause this
problem.

Have you installed a 3rd party libGLU replacement or 3rd party
video drivers which modify the libGLU and/or libGL symlinks during
tarball installation?

Comment 4 Mike A. Harris 2004-03-30 17:38:48 EST
*** Bug 119097 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2004-03-30 17:46:50 EST
>It looks like it was still a bug in RHEL3 Update 1, but got fixed in
>RHEL3 Update 2 Beta1.  Thanks!

I've investigated all of the released packages that have been
released by Red Hat as part of the RHEL 3 initial release, and
all subsequent errata packages for both x86_64 and i386 architecture,
and all of the libGLU and libGL symlinks are correctly installed
in the proper location and pointing to the correct files in each
case.

I have done a test installation of RHEL 3 for x86_64, and then
added the libGLU library from the RHEL3 i386 release and it's
dependancies, and then examined the system afterwards, and the
libGLU library is correctly installed, with the symlinks pointing
to the proper 32 bit libraries for the i386 packages, and the
links for the 64bit dirs pointing to the proper files in lib64
directories.

Closing this issue as resolution "WORKSFORME" for now, as we do not
supply libGLU officially in RHEL3 as an official package currently,
and when I add the package from the x86 release, I am unable to
reproduce the problem.

If this problem recurs for you, please feel free to reopen the
report, and if possible review comment #3 above and provide any
feedback you think may be useful, and we can reinvestigate the
issue.

Thanks Mark
Comment 6 Mike A. Harris 2004-11-16 00:53:40 EST
*** Bug 138005 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.