Bug 1380097 - Apper: drop widget style hack
Summary: Apper: drop widget style hack
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apper
Version: 24
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-28 16:03 UTC by Kevin Kofler
Modified: 2016-12-11 19:27 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-12-11 19:27:23 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2016-09-28 16:03:06 UTC
Description of problem:
Apper currently ships with a downstream hack (apper-0.9.2-style.patch) that makes it refuse to use the systemwide Qt widget style. This was done to workaround a harmless, purely cosmetic glitch (bug #1209017). But it causes a much worse cosmetic glitch: the application looks just completely off. Just compare the big progress bar on a stock Fedora 24 installation (where Oxygen is not available, and thus Cleanlooks is used) with a Breeze progress bar. It just looks completely wrong. Native KDE applications must not be disguising themselves as GTK+ applications when running under Plasma.

Version-Release number of selected component (if applicable):
apper-0.9.2-6.fc24

How reproducible:
Always

Steps to Reproduce:
1. Use Apper.

Actual results:
Uses an ugly look&feel.

Expected results:
Looks&feels like a native KDE application.

Additional info:
If you care so strongly about the bug #1209017 glitch, please fix it properly, or get the Breeze developers to fix it properly. (It is probably a bug in their style.) It is absolutely not acceptable for every single application to work around style bugs by hardcoding some style. That will only lead to an inconsistent hodgepodge of differently-looking applications, and by hiding the real problem, it also makes it unlikely it will ever get fixed.

Comment 1 Kevin Kofler 2016-09-28 16:04:42 UTC
I also disagree with the comment on your patch claiming it is "upstreamable". Such gross hacks are absolutely NOT acceptable in upstream code (nor downstream, IMHO).

Comment 2 Kevin Kofler 2016-09-28 16:07:29 UTC
Oh, and the bug #1209017 glitch has been there for years, probably for as long as Apper exists at all, with the Quarticurve theme. I have never seen an Apper without that glitch. It is perfectly usable anyway.

Comment 3 Rex Dieter 2016-09-28 16:32:00 UTC
Sorry if I marked the patch upstreamable, I agree that it is not.

That said, I thought we were doing to discuss this first onlist and only move to change things if there's a consensus?


either way, my personal opinion is still the same: that forcing the use of a known good/working style is preferable to layout issues (that sometimes make text unreadable).

Comment 4 Kevin Kofler 2016-09-28 17:13:20 UTC
At the very least, you should add something like Krita's KRITA_NO_STYLE_OVERRIDE (see line 162 here: https://quickgit.kde.org/?p=krita.git&a=blob&h=4d43185fc5d7a388ddde274bc04ffc48b2cdfccd&hb=044694c89b3511e0b4f00ded11c2be12d42eaee8&f=libs%2Fui%2FKisApplication.cpp ).

But I think Apper would really be better to use the correct style by default. People who want to override it can do it (just use the menu editor and add --style=whatever). This doesn't need to be hardcoded in the code at all.

Comment 5 Jonathan Wakely 2016-09-28 17:43:45 UTC
(In reply to Kevin Kofler from comment #4)
> But I think Apper would really be better to use the correct style by
> default. People who want to override it can do it (just use the menu editor
> and add --style=whatever). This doesn't need to be hardcoded in the code at
> all.

Most users will have no idea that they can override the style to make the text legible, or that the garbled text isn't actually very useful, they just see illegible text and don't know what it says. The default for regular users should be legible text. If the inconsistent style hurts your eyes then use the environment variable, don't force your preference for style over substance on everyone else.

Comment 6 Kevin Kofler 2016-09-28 17:44:03 UTC
> That said, I thought we were doing to discuss this first onlist and only move
> to change things if there's a consensus?

I thought you wanted to do it on IRC, and since this was not discussed in an IRC meeting (this week's meeting was skipped instead), I figured I need to file this bug to get things moving. But here's it on the mailing list:
http://www.spinics.net/linux/fedora/fedora-kde/msg18097.html

Comment 7 Kevin Kofler 2016-09-28 17:49:08 UTC
> Most users will have no idea that they can override the style

--style=… is a standard parameter for all Qt apps. It is a lot more discoverable than an undocumented application-specific environment variable, or worse, having to recompile the code (or patch the binary, ewww!) as it stands now.

> they just see illegible text and don't know what it says.

Now instead they see an application that looks bad, which makes them think, consciously or subconsciously, that Fedora is a bad distribution because it cannot even make KDE applications look consistent with each other. Even if they do not immediately notice the wrong theme, it still subconsciously looks "messy".

> The default for regular users should be legible text.

99% of the text in the app is legible. It is only that progress status (that is not even correct with PackageKit-hif to begin with!) that is not.

> If the inconsistent style hurts your eyes then use the environment variable,
> don't force your preference for style over substance on everyone else.

It is not a preference for style over substance, it is a preference for a local cosmetic glitch (a detail looks broken) over a global one (the whole application looks broken).

Comment 8 Rex Dieter 2016-09-28 17:55:35 UTC
bz is not a good forum for discussion and debate, please followup onlist per comment #6

Comment 9 Kevin Kofler 2016-11-04 22:56:42 UTC
Grrr, still no update here, after a month!

I ran:
sudo sed -i -e s/KDE_FULL_SESSION/KDE_FOOL_SESSION/g /usr/bin/apper
to stop it from looking like crap here.

And ironically, the Cleanlooks style your hack uses instead actually has much worse graphical glitches. In the Cleanlooks style, if I click on a package, the description does not render until I click inside the text, or where the text should be (a glitch I also had with Quarticurve – Quarticurve also had the same glitch with the overlapping progress text as Breeze though). With Breeze, showing the description just works. We really need to kill that style override.

Comment 10 Rex Dieter 2016-11-07 16:27:31 UTC
For what it's worth, I cannot reproduce the problem you describe in comment #9 about updates text not rendering (until you click it).

(though honestly, PK lot longer to load the data than expected... )

Comment 11 Kevin Kofler 2016-11-07 17:32:39 UTC
You probably have the Oxygen Qt 4 style installed. I don't (this is a fresh F24 install on a new computer), so your hack uses Cleanlooks instead.

Comment 12 Rex Dieter 2016-11-07 17:59:14 UTC
I know, I did purposely remove oxygen first (and indeed cleanlooks very different than oxygen)

Comment 13 Rex Dieter 2016-11-10 13:22:33 UTC
OK, I can reproduce this now, and I agree that's pretty horrible. :(

In the end, the only style that works well still seems to be oxygen.  So, I think I'll go with:

1. modify patch to only try using alternative style oxygen (if available)

2.  add Recommends: qt?-style-oxygen

Comment 14 Fedora Update System 2016-11-10 14:58:43 UTC
apper-0.9.2-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5295dc586

Comment 15 Kevin Kofler 2016-11-10 19:00:47 UTC
Your fix looks acceptable (with also the opt-out environment variable), I'd still like the hack to just go away though. :-)

Comment 16 Fedora Update System 2016-11-11 05:03:11 UTC
apper-0.9.2-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5295dc586

Comment 17 Fedora Update System 2016-11-21 02:22:33 UTC
apper-0.9.2-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-12-08 13:13:34 UTC
apper-0.9.3-0.4.20161109.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-42e3aac51f

Comment 19 Fedora Update System 2016-12-08 19:26:56 UTC
apper-0.9.3-0.4.20161109.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-42e3aac51f

Comment 20 Fedora Update System 2016-12-11 19:27:23 UTC
apper-0.9.3-0.4.20161109.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.