Bug 1380602 - RHEL 7.3: have rbd multipathd checker set lock_on_read rbd map setting
Summary: RHEL 7.3: have rbd multipathd checker set lock_on_read rbd map setting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
Steven J. Levine
URL:
Whiteboard:
Depends On:
Blocks: 1378186 1379890 1395298
TreeView+ depends on / blocked
 
Reported: 2016-09-30 05:22 UTC by Mike Christie
Modified: 2017-08-02 08:13 UTC (History)
16 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-100.el7
Doc Type: Bug Fix
Doc Text:
Read requests sent after failed writes will always return the same data on multipath devices Previously, if a write request wass hung in the `rbd` module, and the iSCSI initiator and multipath layer decided to fail the request to the application, read requests sent after the failure may not have reflected the state of the write. This was because When a Ceph `rbd` image is exported through multiple iSCSI targets, the `rbd` kernel module will grab the exclusive lock when it receives a write request. With this fix, The `rbd` module will grab the exclusive lock for both reads and writes. This will cause hung writes to be flushed and or failed before executing reads. As a result, read requests sent after failed writes will always return the same data.
Clone Of:
: 1395298 (view as bug list)
Environment:
Last Closed: 2017-08-01 16:34:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1961 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2017-08-01 17:56:09 UTC

Description Mike Christie 2016-09-30 05:22:57 UTC
Description of problem:

Issue #2 in this bz:

https://bugzilla.redhat.com/show_bug.cgi?id=1378186

required a new rbd mapping option. This bz is to have multipathd's rbd checker pass the lock_on_read to rbd map.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Ben Marzinski 2016-11-09 19:27:23 UTC
applied "rbd: use lock_on_read if set" patch

http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=commit;h=eeedea6b066ba99308aca3f286aef13b9c93c85e

Comment 14 Steven J. Levine 2017-05-05 21:42:55 UTC
Rearranging doc text for release note format.

Ben: I'm not finding Mike Christie in Red Hat email, so could you check what the doc text now says, to be sure that the sentence rearrangement doesn't change the meaning?  The only thing I actually changed was to  add the word "multipath" to the summary title, to clarify that this is a multipath bz (in the context of the release notes), but if that is not correct please let me know.

Comment 15 Ben Marzinski 2017-05-08 16:44:46 UTC
This looks good to me.

Comment 16 Mike Christie 2017-05-08 17:29:01 UTC
I'm here still :) Not sure what happened to my email.

This looks ok to me. Thanks Ben and Steven.

Comment 23 errata-xmlrpc 2017-08-01 16:34:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1961


Note You need to log in before you can comment on or make changes to this bug.