Bug 1381432 - L10N - update DNF 2.0 strings in Zanata so we can translate and fix tiny localization issues
Summary: L10N - update DNF 2.0 strings in Zanata so we can translate and fix tiny loca...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 24
Hardware: Unspecified Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n, Triaged, UserExperience
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-04 05:40 UTC by jibecfed
Modified: 2016-12-03 15:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-18 05:31:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jibecfed 2016-10-04 05:40:40 UTC
Description of problem:
You release a new version of DNF :
http://dnf.baseurl.org/2016/10/03/dnf-2-0-0-and-dnf-plugins-core-1-0-0-released/

But in Zanata, la push from your project is "12/05/16 22:13 by jsilhan".
If V. 1.0 will live in parallel of 2.0, you may create one branche for 2.0 and rename the current in 1.0 in Zanata. But I think v2.0 replace v1.0, so 1 branch is fine.

Can you please:
* Push new strings to Zanata.
* Tell us if 100% to have a 100% translated experience of DNF, those 4 packages are sufficient : https://fedora.zanata.org/search/DNF or if some other also have to be translated.



Additional info, you have a minor translation issues that would be easy fixed:
https://bugzilla.redhat.com/show_bug.cgi?id=1298717
=> I haven't found this string "Already downloaded" in dnf repositories, and I confirm this issue with fr_FR.

https://bugzilla.redhat.com/show_bug.cgi?id=1302935
=> I confirm this issue with fr_FR, "package" is no translated.

https://bugzilla.redhat.com/show_bug.cgi?id=1305340
=> You may just add one gettext comment to each string, it should make two different lines po file and solve the user issue.

https://bugzilla.redhat.com/show_bug.cgi?id=1321180
=> I miss the needed skills to reproduce the bug, but it's probably just a few missing marked strings.

Comment 1 Igor Gnatenko 2016-10-04 06:35:10 UTC
Only jsilhan has access to zanata. I will check other bugs.

Comment 2 Honza Silhan 2016-10-11 19:56:04 UTC
The other bugs are not so easy to fix. it's not just about wrapping the string literal with underscore.

Zanata updated to DNF-2.0 strings and recent translations are pulled in in PR: https://github.com/rpm-software-management/dnf/pull/633

Having translations for all four project is perfect. Thanks.

Comment 3 jibecfed 2016-10-18 05:31:04 UTC
looks like your PR is done, and content in Zanata, thank you Jan

Comment 4 jibecfed 2016-12-03 12:19:03 UTC
it's been a while DNF is 100% in French (and I talk about dnf, dnf-plugins-core, dnf-plugins-extra,  dnf-plugin-system-upgrade, a total of 4000 words), while it is still untranslated on my systems...

You pushed new content, probably one or two ours of work... Ok, let's translate it again... Review it again with the team... But I would be really happy to have more frequent pull/push, with less strings to translate while without seeing any improvement on my system.

Please have a clear process to nicely handle internationalization, frequent translation and make our work reach end-user. Otherwise we just make useless work, and at the end we will stop translating it and saying everywhere "sorry, dev don't care".

Maybe you should just use a tool directly connected to your git so you do not have to care about this problems ? Have a look to http://hosted.weblate.org/

Whatever you do, please do it.

Comment 5 Piotr Drąg 2016-12-03 15:40:33 UTC
Regular pull/push of translations would be highly appreciated, but moving out of Fedora infrastructure is not a good idea, for many reasons.


Note You need to log in before you can comment on or make changes to this bug.