Bug 138189 - bold fonts fail to print in OOo, (postscriptname for Bold/Italic/Normal fonts are the same)
Summary: bold fonts fail to print in OOo, (postscriptname for Bold/Italic/Normal fonts...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ttfonts-indic (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Darshan Santani
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Keywords: i18n
: 157915 (view as bug list)
Depends On:
Blocks: Indic 137790 157915
TreeView+ depends on / blocked
 
Reported: 2004-11-05 14:38 UTC by Jatin Nansi
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 11:04:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the test sxw (5.54 KB, application/octet-stream)
2004-11-05 14:41 UTC, Jatin Nansi
no flags Details
printout with normal text (324.05 KB, application/octet-stream)
2004-11-05 14:43 UTC, Jatin Nansi
no flags Details
printout with bold text (329.40 KB, application/octet-stream)
2004-11-05 14:46 UTC, Jatin Nansi
no flags Details
output with I do some magic with the font (397.04 KB, application/postscript)
2005-06-16 14:17 UTC, Caolan McNamara
no flags Details
fixed font (82.81 KB, application/x-font-ttf)
2005-06-16 14:18 UTC, Caolan McNamara
no flags Details
postscriptname dumper (457 bytes, text/x-csrc)
2005-06-16 14:20 UTC, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 50814 None None None Never

Description Jatin Nansi 2004-11-05 14:38:20 UTC
Description of problem:
Printing of hindi text fails totally, if even one hindi word is made
bold. 


Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-10


How reproducible:
Every time


Steps to Reproduce:
1. open the attached .sxw in writer.
2. print the doc.
3. make the one bold hindi word normal.
4. print the doc.
  

Actual results:
The printout is perfect in case of regular text.
In case of bold text, all the hindi text is garbage - only the
characters from the bold word and squares are repeated over and over
again, wherever hindi text should print in bold.


Expected results:
Printing should be proper in all cases


Additional info:
Attaching a test sxw, and the postscript outputs of the sxw.
The ttfonts-hi package (providing lohit fonts) included on rawhide
does not contain bold fonts. Get the packages containing bold fonts
here: http://bob.brisbane.redhat.com/~jnansi/pkgs/

Comment 1 Jatin Nansi 2004-11-05 14:41:23 UTC
Created attachment 106215 [details]
the test sxw

Comment 2 Jatin Nansi 2004-11-05 14:44:00 UTC
Created attachment 106216 [details]
printout with normal text

Comment 3 Jatin Nansi 2004-11-05 14:46:39 UTC
Created attachment 106217 [details]
printout with bold text

Comment 4 Leon Ho 2004-11-05 17:51:15 UTC
I can reproduce it on Tamil as well so i assume it affects all 5 Indic
langs

Comment 6 Dan Williams 2004-12-09 22:31:35 UTC
I cannot reproduce on this configuration:
openoffice.org-1.1.2-16.6.EL4
ttfonts-hi-1.7-1

Note that I don't see the bold text onscreen, but I do see it in the
printout.  I may not have the bold fonts though.  So either we fixed
this along the way, or the bold font itself causes OOo to barf.  Could
somebody test this with the bold font on 1.1.2-16.6 or later?

Comment 7 Dan Williams 2004-12-09 22:34:13 UTC
Ok, nevermind, its still a problem.  Installing the bold font screws
it up.  It will require more investigation...

Comment 11 Caolan McNamara 2005-06-16 14:17:25 UTC
Created attachment 115537 [details]
output with I do some magic with the font

Comment 12 Caolan McNamara 2005-06-16 14:18:08 UTC
Created attachment 115538 [details]
fixed font

Comment 13 Caolan McNamara 2005-06-16 14:20:15 UTC
Created attachment 115539 [details]
postscriptname dumper

Comment 14 Caolan McNamara 2005-06-16 14:27:54 UTC
Ok, the postscript name for the Lohit Hindi and Lohit Hindi Bold fonts is the
same, it's Lohit-Hindi for the normal one, and should be Lohit-Hindi-Bold or
something different for the other one. Presumably this is why rh#157914# is also
a problem.

Attached is a simple program to dump the postscript name of a ttf fontfile so as
to double check the postscript name of other fonts.

Also attached is the Lohit_Hindi_Bold ttf file, except with it's postscript name
hacked to be Lohit-Hindb. If you replace your system original with the above
copy, and then remove OOo's cache of fonts of
~/.rhopenoffice/user/psprint/pspfontcache/~.openoffice.org2.0/user/psprint/pspfontcache
and try again you should get the correct postscript as attached.

so it's really a problem of the font IMO

Comment 15 Caolan McNamara 2005-06-16 14:54:40 UTC
*** Bug 157915 has been marked as a duplicate of this bug. ***

Comment 16 Leon Ho 2005-06-17 07:11:04 UTC
Thanks for your effort Caolan! I have tested it against OOo and evolution and it
should be as you said - a font problem as the postscript name on normal and bold
weight are the same. I have already sent the request to the font vendors to get
the official change.

This is good to be in, however I cannot ACK it unless we have tested all those
'fixed' bold fonts for all tier-1 applications.


Comment 19 Leon Ho 2005-08-04 01:01:23 UTC
Font vendor has not give us the update bold fonts with all those fixed mentioned
above. It is a risk if they are included. Moving to RHEL4U3Proposed.


Note You need to log in before you can comment on or make changes to this bug.