Bug 1382447 - mktexfmt cannot find fmtutil.cnf
Summary: mktexfmt cannot find fmtutil.cnf
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-06 17:47 UTC by Avram Lubkin
Modified: 2018-10-10 12:20 UTC (History)
6 users (show)

Fixed In Version: texlive-2016-17.20160520.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 00:41:07 UTC
Type: Bug


Attachments (Terms of Use)
Errors in Sphinx tests with rawhide tex release -16 (48.48 KB, text/plain)
2016-10-26 20:38 UTC, Avram Lubkin
no flags Details

Description Avram Lubkin 2016-10-06 17:47:22 UTC
Description of problem:

Encountered problems building python-sphinx for rawhide
Issue was traced back to pdfTeX(3.14159265-2.6-1.40.17) error:
  I can't find the format file `latex.fmt`!

Traced this to a problem with "mktexfmt latex.fmt" not finding fmtutil.cnf

For simplicity, "kpsewhich -all fmtutil.cnf" returns no output

Version-Release number of selected component (if applicable):
texlive-kpathsea-bin-svn40473-6.20160520.fc26.1.x86_64

How reproducible:
Very

Steps to Reproduce:
1."kpsewhich -all fmtutil.cnf"
2.
3.

Actual results:
Nothing Returned

Expected results:
/usr/share/texlive/texmf-dist/web2c/fmtutil.cnf

Additional info:

In F24 and F25 (texlive-kpathsea-bin-svn37207.0-24.20150728_r37987), "kpsewhich -all fmtutil.cnf" returns as expected and "mktexfmt latex.fmt" is successful.

Am I missing a dependency, is this a bug, or is this new behaviour?

Comment 1 Tom "spot" Callaway 2016-10-06 19:46:24 UTC
I think this is fixed with the -7 update that is building now, there were some incorrect Obsoletes affecting texlive-kpathsea. Do you have the matching texlive-kpathsea installed?

Comment 2 Avram Lubkin 2016-10-06 20:16:03 UTC
I have the latest for both, though the svn numbers don't match.

rpm -qa | grep kpathsea
texlive-kpathsea-bin-svn40473-6.20160520.fc26.1.x86_64
texlive-kpathsea-svn41139-6.fc26.1.noarch

I'll try out -7 when it's finished

Comment 3 Tom "spot" Callaway 2016-10-06 20:28:19 UTC
Okay, and just to sanity check, /usr/share/texlive/texmf-dist/web2c/fmtutil.cnf exists?

Comment 4 Avram Lubkin 2016-10-06 21:35:38 UTC
Yes, it exists

grep -v "^#" /usr/share/texlive/texmf-dist/web2c/fmtutil.cnf

latex pdftex language.dat -translate-file=cp227.tcx *latex.ini
pdflatex pdftex language.dat -translate-file=cp227.tcx *pdflatex.ini
dvilualatex luatex language.dat,language.dat.lua dvilualatex.ini
lualatex luatex language.dat,language.dat.lua lualatex.ini
luajitlatex luajittex language.dat,language.dat.lua lualatex.ini
luatex luatex language.def,language.dat.lua luatex.ini
dviluatex luatex language.def,language.dat.lua dviluatex.ini
luajittex luajittex language.def,language.dat.lua luatex.ini
mf mf-nowin - -translate-file=cp227.tcx mf.ini
mf mf-nowin - -translate-file=cp227.tcx mf.ini
mptopdf pdftex - -translate-file=cp227.tcx mptopdf.tex
pdftex pdftex language.def -translate-file=cp227.tcx *pdfetex.ini
etex pdftex language.def -translate-file=cp227.tcx *etex.ini
pdfetex pdftex language.def -translate-file=cp227.tcx *pdfetex.ini
tex tex - tex.ini
tex tex - tex.ini

Comment 5 Avram Lubkin 2016-10-08 14:49:44 UTC
Same behaviour with -7

$ rpm -qa | grep kpathsea
texlive-kpathsea-svn41139-7.fc26.1.noarch
texlive-kpathsea-bin-svn40473-7.20160520.fc26.1.x86_64

$ kpsewhich -all fmtutil.cnf
(no output)

$ mktexfmt latex.fmt
(Finds no fmtutil.cnf files)

I ran strace for kpsewhich and compared F24 with Rawhide. It seems the problem is the ls-R files, particularly /usr/share/texlive/texmf-dist/ls-R are missing. It looks like these are ghost files and are supposed to be generated with texhash, but it looks like that isn't happening.

Comment 6 Tom "spot" Callaway 2016-10-10 14:15:02 UTC
Okay. I figured this out. I moved to using triggers in the texlive package to try to speed up things.

Before, we had this (on every subpackage):

%postun
if [ $1 == 1 ]; then
  mkdir -p /var/run/texlive
  touch /var/run/texlive/run-texhash
else
  %{_bindir}/texhash 2> /dev/null
fi

%posttrans
if [ -e /var/run/texlive/run-texhash ] && [ -e %{_bindir}/texhash ]; then %{_bindir}/texhash 2> /dev/null; rm -f /var/run/texlive/run-texhash; fi

Now, we have this (only on the texlive core package):

%transfiletriggerin -- %{_texdir}
%{_bindir}/texhash 2> /dev/null
export TEXMF=/usr/share/texlive/texmf-dist
export TEXMFCNF=/usr/share/texlive/texmf-dist/web2c
export TEXMFCACHE=/var/lib/texmf
%{_bindir}/mtxrun --generate &> /dev/null
%{_bindir}/fmtutil-sys --all &> /dev/null

%transfiletriggerpostun -- %{_texdir}
%{_bindir}/texhash 2> /dev/null

That _should_ result in texhash being executed once after transaction for all installed packages that contained file(s) that matches prefix of this trigger (/usr/share/texlive). Also executed after transaction if there was a package containing this file trigger in that transaction and there is/are some files(s) matching prefix of this trigger in rpmdb. 

But! Here is the issue (I think). I put the triggers on the "texlive" subpackage, but texlive-kpathsea doesn't actually depend on texlive, it's the other way around. texlive-kpathsea is at the top of the dependency chain. Moving these triggers to the kpathsea subpackage _should_ fix this. I'll do that in -8.

Comment 7 Gianluca Sforna 2016-10-11 14:40:12 UTC
Tried rebuilding rdkit against -8, before I had:

I can't find the format file `pdflatex.fmt'!

now error is different:
https://kojipkgs.fedoraproject.org//work/tasks/9795/16049795/root.log

DEBUG util.py:421:  Last metadata expiration check: 0:01:23 ago on Tue Oct 11 14:29:20 2016.
DEBUG util.py:421:  Error: package texlive-wrapfig-5:svn22048.3.6-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-upquote-5:svn26059.v1.3-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-titlesec-5:svn40129-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-threeparttable-5:svn17383.0-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-multirow-5:svn17256.1.6-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-framed-5:svn26789.0.96-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-eqparbox-5:svn29419.4.0-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-capt-of-5:svn29803.0-8.fc26.1.noarch requires texlive-kpathsea-bin, but none of the providers can be installed.
DEBUG util.py:421:  nothing provides texlive-kpathsea-lib(x86-64) = 5:2016 needed by texlive-dvipng-bin-5:svn40473-8.20160520.fc26.1.x86_64.
DEBUG util.py:421:  nothing provides texlive-kpathsea-lib(x86-64) = 5:2016 needed by texlive-dvipng-bin-5:svn40473-8.20160520.fc26.1.x86_64.
DEBUG util.py:421:  package texlive-collection-fontsrecommended-5:svn35830.0-8.20160520.fc26.1.noarch requires tex-avantgar, but none of the providers can be installed.
DEBUG util.py:421:  package texlive-collection-latexrecommended-5:svn35765.0-8.20160520.fc26.1.noarch requires tex-anysize, but none of the providers can be installed

just let me know if you would like another bug opened for this.

Comment 8 Tom "spot" Callaway 2016-10-11 14:41:36 UTC
Nope. That is already open as https://bugzilla.redhat.com/show_bug.cgi?id=1383649 and -9 (which should fix it) is building now.

Comment 9 Avram Lubkin 2016-10-19 14:28:06 UTC
Seems better, but still having issues. The python-sphinx tests are fine in F24 and F25, but still fail in Rawhide against -12.

Below is the output for the failure. 


This is LuaTeX, Version 0.95.0 (TeX Live 2016) 
 restricted system commands enabled.
(./SphinxTests.tex
LaTeX2e <2016/03/31>
Babel <3.9r> and hyphenation patterns for 1 language(s) loaded.
(./sphinxhowto.cls
Document Class: sphinxhowto 2009/06/02 Document class (Sphinx HOWTO)
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo))) (./iftex.sty)
(/usr/share/texlive/texmf-dist/tex/latex/cmap/cmap.sty

Package cmap Warning: pdftex not detected - exiting.

) (/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/t1enc.def))
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amstext.sty
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/usr/share/texlive/texmf-dist/tex/latex/amsmath/amsopn.sty))
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/amssymb.sty
(/usr/share/texlive/texmf-dist/tex/latex/amsfonts/amsfonts.sty))
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.sty
(/usr/share/texlive/texmf-dist/tex/generic/babel/luababel.def)
(/usr/share/texlive/texmf-dist/tex/generic/babel-english/english.ldf
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.def
(/usr/share/texlive/texmf-dist/tex/generic/babel/luababel.def))))
(/usr/share/texlive/texmf-dist/tex/latex/psnfss/times.sty) (./fncychap.sty)
(/usr/share/texlive/texmf-dist/tex/latex/tools/longtable.sty) (./sphinx.sty
(/usr/share/texlive/texmf-dist/tex/latex/fancyhdr/fancyhdr.sty)
(/usr/share/texlive/texmf-dist/tex/latex/base/textcomp.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/ts1enc.def))
(/usr/share/texlive/texmf-dist/tex/latex/fancybox/fancybox.sty
Style option: `fancybox' v1.4 <2010/05/15> (tvz)
) (/usr/share/texlive/texmf-dist/tex/latex/titlesec/titlesec.sty)
(./tabulary.sty (/usr/share/texlive/texmf-dist/tex/latex/tools/array.sty))
(/usr/share/texlive/texmf-dist/tex/latex/base/makeidx.sty)
(/usr/share/texlive/texmf-dist/tex/latex/framed/framed.sty)
(/usr/share/texlive/texmf-dist/tex/latex/base/ifthen.sty)
(/usr/share/texlive/texmf-dist/tex/latex/xcolor/xcolor.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics-cfg/color.cfg)

! LaTeX Error: File `luatex.def' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: def)

Enter file name: 
! Emergency stop.
<read *> 
   
l.226 ...ned{ver@\Gin@driver}{\input{\Gin@driver}}{}
                                                  
 410 words of node memory still in use:
   2 hlist, 1 rule, 1 dir, 10 glue, 48 glue_spec, 1 if_stack, 1 write nodes
   avail lists: 2:11,3:2,4:1,7:4,8:3,9:2
!  ==> Fatal error occurred, no output PDF file produced!

Comment 10 Tom "spot" Callaway 2016-10-19 15:20:37 UTC
texlive is such a hot mess. -14 (building now) will have a "texlive-graphics-def" subpackage which includes luatex.def. I also made the texlive-luatex package depend on it.

This should resolve this failure. Thanks for your patience.

Comment 11 Fedora Update System 2016-10-26 20:34:00 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 12 Avram Lubkin 2016-10-26 20:38:24 UTC
Created attachment 1214421 [details]
Errors in Sphinx tests with rawhide tex release -16

Seem to be further along, but still having issues. I'm a little lost when it comes to Tex, but it looks like most of the errors are undefined references related to "py@TitleColor" Is there a new dependency I should be including? Error log is attached.

Comment 13 Fedora Update System 2016-10-28 00:41:07 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Tom "spot" Callaway 2016-11-01 17:41:29 UTC
(In reply to Avram Lubkin from comment #12)
> Created attachment 1214421 [details]
> Errors in Sphinx tests with rawhide tex release -16
> 
> Seem to be further along, but still having issues. I'm a little lost when it
> comes to Tex, but it looks like most of the errors are undefined references
> related to "py@TitleColor" Is there a new dependency I should be including?
> Error log is attached.

Avram, this one has me stumped. Can you open an issue with Sphinx and see if they know what might be to blame here?

Comment 15 Avram Lubkin 2016-11-01 18:04:46 UTC
Tom, coincidently I just opened an issue this morning. They had an answer for me within an hour, so I'm guessing they've run into it before. Turns out I needed the texlive-luatex85 package with TexLive 2016. Seems to build and pass all the tests fine now.

Comment 16 Tom "spot" Callaway 2016-11-01 18:12:05 UTC
I'm glad they were able to resolve it so quickly!


Note You need to log in before you can comment on or make changes to this bug.