Bug 1383576 - To be able to introspect nodes after "provide " action
Summary: To be able to introspect nodes after "provide " action
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Honza Pokorny
QA Contact: Ola Pavlenko
URL:
Whiteboard:
: 1427092 1432950 (view as bug list)
Depends On:
Blocks: 1440276 1469882
TreeView+ depends on / blocked
 
Reported: 2016-10-11 06:14 UTC by Dan Macpherson
Modified: 2018-02-05 19:02 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-ui-7.4.2-2.el7ost
Doc Type: Enhancement
Doc Text:
This update adds an action to "Manage Nodes" through the director UI. This action switches nodes to a "manageable" state so the director can perform introspection through the UI.
Clone Of:
: 1440276 (view as bug list)
Environment:
Last Closed: 2017-12-13 20:46:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1594879 None None None 2017-05-03 13:43:24 UTC
Launchpad 1639262 None None None 2017-05-03 13:42:59 UTC
Launchpad 1716671 None None None 2017-09-12 13:09:16 UTC
OpenStack gerrit 482235 None ABANDONED Set nodes to manageable before introspecting 2020-05-26 07:44:41 UTC
OpenStack gerrit 482509 None MERGED Add manage nodes button to nodes list page 2020-05-26 07:44:41 UTC
OpenStack gerrit 510862 None MERGED Listen for messages from internal introspect workflow 2020-05-26 07:44:41 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Dan Macpherson 2016-10-11 06:14:14 UTC
Description of problem:
I select all my nodes and click "Introspect Nodes". The execution fails with the following error for each node:

Failed to run action [action_ex_id=57e4fac2-0f94-4bac-92c4-995b0d857b9b, action_cls='<class 'mistral.actions.action_factory.BaremetalIntrospectionAction'>', attributes='{u'client_method_name': u'introspect'}', params='{u'uuid': u'0e83c63b-89bf-4092-a72b-627a8eceae99', u'new_ipmi_username': None, u'new_ipmi_password': None}'] BaremetalIntrospectionAction.introspect failed: <class 'ironic_inspector_client.common.http.ClientError'>: Invalid provision state for introspection: "available", valid states are "['manageable', 'inspectfail', 'enroll', 'inspecting']"

For OSP10, a node's provision state must be set to "manageable" prior to starting an introspection. So either one of two things needs to happen:

a) The Mistral execution needs to include setting the node to "manageable" prior to running the introspection.

b) Include a button on the TripleO UI that allows you to change the provision state of the node. Maybe a button next to "Provide Nodes" that says "Manage Nodes".

Version-Release number of selected component (if applicable):
OSP 10
openstack-tripleo-ui.1.0.3-1.el7ost

How reproducible:
Always


Steps to Reproduce:
1. Select all registered nodes
2. Click "Introspect Nodes"
3. Get error

Actual results:
See error above


Expected results:
No error and successful introspection

Additional info:

Comment 2 Ola Pavlenko 2017-02-01 15:06:09 UTC
Doesn't reproduce for me on RHOS 10 GA.

Dan,
Could you please provide .json file you've used to register the nodes?
Also, have you registered the nodes via UI or CLI?

Thanks

Comment 3 Ola Pavlenko 2017-03-26 17:10:03 UTC
Reproduced : openstack-tripleo-ui-3.1.0-4.el7ost.noarch

steps:
1. provide a node
2. try to introspect previously provided node


Failed to run action [action_ex_id=9f4fb7e4-b573-447c-8e9f-a2d1040eddb9, action_cls='<class 'mistral.actions.action_factory.BaremetalIntrospectionAction'>', attributes='{u'client_method_name': u'introspect'}', params='{u'uuid': u'024c7e70-0e18-4b7b-a76e-0507885f82e2', u'new_ipmi_username': None, u'new_ipmi_password': None}'] BaremetalIntrospectionAction.introspect failed: <class 'ironic_inspector_client.common.http.ClientError'>: Invalid provision state for introspection: "available", valid states are "['manageable', 'inspectfail', 'enroll', 'inspecting']"

Comment 4 Ola Pavlenko 2017-04-03 12:12:32 UTC
*** Bug 1432950 has been marked as a duplicate of this bug. ***

Comment 6 Jason E. Rist 2017-05-03 13:41:41 UTC
Introduce action that moves available -> manageable
Better error message from tripleo-common (mistral)

Comment 7 Jason E. Rist 2017-05-03 13:43:00 UTC
https://bugs.launchpad.net/tripleo/+bug/1639262

Comment 8 Jason E. Rist 2017-05-03 13:43:25 UTC
https://bugs.launchpad.net/tripleo/+bug/1594879

Comment 9 Udi 2017-06-14 15:41:36 UTC
*** Bug 1427092 has been marked as a duplicate of this bug. ***

Comment 11 Udi 2017-09-06 10:31:33 UTC
If you run the scenario with the latest OSP12, the introspection appears to start but it never ends until the user presses F5. In fact, the introspection didn't even start because you first have to "unmanage" the nodes.

The user should get an error in the GUI if he's trying to introspect nodes before unmanaging them. When unmanaging the node and then introspecting it - the system works fine.

Comment 14 Honza Pokorny 2017-09-12 13:09:16 UTC
I found the source of the issue.  I opened a bug upstream, and I'm waiting for confirmation.

Comment 15 Honza Pokorny 2017-09-14 13:18:08 UTC
Let me point out that there are two issues at play here.

1.  The original bug has been solved like this: instead of setting nodes to manageable before running introspection, we provide a new button on the node list page called "Manage nodes" which can be used to set the nodes to the correct state before introspection.  This has the benefit of not obscuring Ironic's states and mechanism.

2.  There is a regression in introspection error handling.  If introspection fails, the loaders on the node list page keep spinning forever.  This is Udi's bug from 2017-09-06.  This bug is now proposed upstream.

https://review.openstack.org/#/c/504035/

Comment 18 Jason E. Rist 2017-10-26 14:02:28 UTC
https://review.openstack.org/#/c/510862/ merged upstream stable/pike

Comment 20 Udi 2017-11-20 14:45:53 UTC
Verified in openstack-tripleo-ui-7.4.3-2.el7ost.noarch

Comment 23 errata-xmlrpc 2017-12-13 20:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.