Bug 1469882 - [Docs][RFE][UI] Tracker for Minor UI RFEs
[Docs][RFE][UI] Tracker for Minor UI RFEs
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Dan Macpherson
RHOS Documentation Team
: Triaged
Depends On: 1287086 1301549 1368512 1383576 1408494 1430885 1446430 1476736 1513288 1513624
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 23:34 EDT by Dan Macpherson
Modified: 2017-11-23 00:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-23 00:11:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Macpherson 2017-07-11 23:34:54 EDT
Ensure the following BZ have doc_text for release notes. Some might also require additional minor documentation in guides.

* BZ#1287086 - [Horizon] Add Neutron QoS support
Table 3.2 in the Introduction to the OpenStack Dashboard might need an additional row for Network QoS

* BZ#1301549 - [UX] validate that there are no duplicate IPs as a result of bad templates in nic-configs
Just an additional validation for the Director UI. Might require a release note

* BZ#1368512 - Director should check available resources before deployment/upgrade
A few new upgrade validations for the Director Ui. Might require a release note

* BZ#1383576 - To be able to introspect nodes after "provide " action
This is just an additional UI button and might not need any major documentation. Possibly release note/errata is enough

* BZ#1408494 - rhel-osp-director: Need to add a check for the total count of the nodes - that it doesn't exceed the amount of available nodes in ironic
This is a behind the scenes validation. Might only require doc_text

* BZ#1430885 - As a basic deployer I want meaningful progress information of the deployment
Basic change to the nested stack level. Not much docs impact. Might require a rel note

BZ#1446430 - Horizon support for Neutron Trunks
Might require a release note. CLI should already be documented in Networking Guide
Comment 1 Dan Macpherson 2017-11-10 01:02:43 EST
Regarding BZ#1287086 - [Horizon] Add Neutron QoS support

This feature is disabled by default and will be re-enabled for OSP13.
Comment 2 Dan Macpherson 2017-11-13 01:42:48 EST
Implemented docs text for the following:

* BZ#1301549 - [UX] validate that there are no duplicate IPs as a result of bad templates in nic-configs
Just an additional validation for the Director UI. Might require a release note

* BZ#1368512 - Director should check available resources before deployment/upgrade
A few new upgrade validations for the Director Ui. Might require a release note

* BZ#1383576 - To be able to introspect nodes after "provide " action
This is just an additional UI button and might not need any major documentation. Possibly release note/errata is enough

* BZ#1408494 - rhel-osp-director: Need to add a check for the total count of the nodes - that it doesn't exceed the amount of available nodes in ironic
This is a behind the scenes validation. Might only require doc_text

* BZ#1430885 - As a basic deployer I want meaningful progress information of the deployment
Basic change to the nested stack level. Not much docs impact. Might require a rel note

Have asked engineering team about status of the following RFEs:

* BZ#1287086 - [Horizon] Add Neutron QoS support
Table 3.2 in the Introduction to the OpenStack Dashboard might need an additional row for Network QoS

* BZ#1446430 - Horizon support for Neutron Trunks
Might require a release note. CLI should already be documented in Networking Guide

Both are currently disabled for OSP12 by default and might not be enabled until OSP13.
Comment 3 Dan Macpherson 2017-11-23 00:11:51 EST
Have implemented BZ#1446430 which will be available for OSP12 GA.

BZ#1287086 has been pushed to OSP13. Have cloned into the following docs BZ:

https://bugzilla.redhat.com/show_bug.cgi?id=1513288

Everything in this BZ seems to be done all are minor issues and don't really require peer review. Will close this BZ.

Note You need to log in before you can comment on or make changes to this bug.