Bug 1384627 - Can't pick disk to install boot loader
Summary: Can't pick disk to install boot loader
Keywords:
Status: CLOSED DUPLICATE of bug 1168118
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 25
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F25FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2016-10-13 17:34 UTC by mbw227
Modified: 2016-11-28 01:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-28 01:06:39 UTC
Type: Bug


Attachments (Terms of Use)

Description mbw227 2016-10-13 17:34:38 UTC
Description of problem: When splitting the install up onto two different disks/drives, the disk you select to install boot loader on is ignored.


Version-Release number of selected component (if applicable):


How reproducible: Always happens. So long as the disk you want to install the boot loader on is not the disk Anaconda decides to pick for you.


Steps to Reproduce:
1. Select the "Installation Destination" section on Anaconda.
2. Select two disks you want to split up your Fedora install onto by clicking on them at the top. The disk I want to install the boot loader on happens to be the second disk listed. 
3. At the bottom in blue text, it says "Full disk summary and boot loader". Click this. 
4. It should have the first disk in the list pre-selected as the boot device. Click the second drive in the list, which is the disk we want to install the boot loader on, and click "Set as Boot Device".
5. Click "Close" to close out of that dialogue.
6. Click the radio button "I will configure partitioning."
7. Click "Done" in the top left corner.

Actual results:
After clicking "Done", it takes you to the manual partitioning screen. Clicking "Full disk summary and boot loader ..." in the bottom corner reveals that the boot device you selected earlier was not saved. It has reverted to the first disk in the list. Not only that, but it gives you no option to change this from here. If you ignore this, and choose to install "/boot" to the second disk, the disk that the boot loader was intended to be installed on, it will give you an error.

Expected results:
The boot device selected on the previous screen should be the boot device that's selected on the manual partitioning screen. If it isn't, it should be at least possible to change it from this section of the installer.

Additional info:
You can get around this by ignoring the the boot device selected, and setting up your partitions the way you would if the intended boot device was selected. After picking your partition scheme, click "Done" twice. It will tell you there was an error checking storage devices. Click on "Installation Destination" again, and repeat the ""Steps to Reproduce". This time, the selected boot device will be saved.

Comment 1 Adam Williamson 2016-11-19 01:20:44 UTC
This is almost certainly https://bugzilla.redhat.com/show_bug.cgi?id=1303217 , right?

Comment 2 mbw227 2016-11-27 22:45:09 UTC
(In reply to Adam Williamson from comment #1)
> This is almost certainly https://bugzilla.redhat.com/show_bug.cgi?id=1303217
> , right?

It looks like it probably is, but the other one wasn't very detailed.

Comment 3 Adam Williamson 2016-11-28 01:06:39 UTC
Sorry, that's a RHEL clone. The true original is https://bugzilla.redhat.com/show_bug.cgi?id=1168118 .

*** This bug has been marked as a duplicate of bug 1168118 ***


Note You need to log in before you can comment on or make changes to this bug.