Bug 1384744 - Duplicate host entry after provisioning new hosts in satellite 6.2.2
Summary: Duplicate host entry after provisioning new hosts in satellite 6.2.2
Keywords:
Status: CLOSED DUPLICATE of bug 1380473
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.2.2
Hardware: x86_64
OS: Linux
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-14 03:51 UTC by Amit Kumar Das
Modified: 2017-04-25 16:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-17 16:32:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
contenthostduplicate screenshot (44.18 KB, image/png)
2016-10-14 03:51 UTC, Amit Kumar Das
no flags Details

Description Amit Kumar Das 2016-10-14 03:51:02 UTC
Created attachment 1210336 [details]
contenthostduplicate screenshot

Description of problem:

Customer is provisioning new hosts in vmware vsphere from satellite 6.2.2 (fresh installation) . They found duplicate host entry, one with shortname, one with fqdn.

The issue is similar of Bug 1356714. As per recommendation, errata is applied
and packages are up-to-date but the issue is revisited and hosts are having duplicate entry in satellite GUI.

Version-Release number of selected component (if applicable):
satellite-6.2.2

How reproducible:
--As per cu--
OK, so I have my vSphere (5.5) clusters added as compute resources. I build a machine using compute profiles I setup. The server builds the VM fine but once the packages have installed and goes through the postbuild is when a second entry is created, specifically around the time it tries to register the system. When it registers the system it creates a new system in hosts without an FQDN, as a result it even fails to install VMware tools despite it's part of the content view.

Actual results:
Duplicate hosts entry in sat 6.2.2

Expected results:

Comment 4 Justin Sherrill 2016-10-17 16:32:18 UTC
I think this is a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1380473  currently targeted to 6.2.4.  Note there is a workaround as detailed here:  https://bugzilla.redhat.com/show_bug.cgi?id=1356714#c31


I'll go ahead and close as a dup, feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of bug 1380473 ***


Note You need to log in before you can comment on or make changes to this bug.