Bug 1380473 - Puppet creates Duplicate profile in "All hosts" with FQDN if client is configured and registered with short name.
Summary: Puppet creates Duplicate profile in "All hosts" with FQDN if client is confi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades
Version: 6.2.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Sanket Jagtap
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1384744 1388765 (view as bug list)
Depends On: 1356714 1405538
Blocks: 1399395 1383793 CEE_Sat6_Top_BZs, GSS_Sat6_Top_Bugs 1394349 1400970
TreeView+ depends on / blocked
 
Reported: 2016-09-29 17:13 UTC by Justin Sherrill
Modified: 2019-08-12 14:36 UTC (History)
31 users (show)

Fixed In Version: katello-agent-2.7.0-1 tfm-rubygem-katello-3.0.0.86-1 katello-installer-base-3.0.0.65-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1356714
: 1394349 (view as bug list)
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 16134 'High' 'Closed' 'Registering system with shotname hostname results in duplicate host entries' 2019-12-02 15:15:55 UTC
Red Hat Knowledge Base (Solution) 2482641 None None None 2016-09-29 17:13:48 UTC

Comment 1 Justin Sherrill 2016-09-29 17:20:42 UTC
Connecting redmine issue http://projects.theforeman.org/issues/16134 from this bug

Comment 2 Justin Sherrill 2016-09-29 17:22:10 UTC
Current workaround: run this:


if [ -d /etc/rhsm/facts/ ]; then
  echo "{\"network.hostname\":\"`hostname -f`\"}" > /etc/rhsm/facts/katello.facts
fi

prior to registration to resolve the issue for new registrations.  This can be added to a bootstrap script, kickstart file, or puppet module.  Please do let us know if this workaround is not sufficient until this can be released

Comment 4 Bryan Kearney 2016-09-29 20:19:25 UTC
Upstream bug component is Upgrades

Comment 8 Bryan Kearney 2016-10-05 14:14:48 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16134 has been resolved.

Comment 9 Justin Sherrill 2016-10-17 16:32:18 UTC
*** Bug 1384744 has been marked as a duplicate of this bug. ***

Comment 12 Brad Buckingham 2016-10-31 18:45:21 UTC
*** Bug 1388765 has been marked as a duplicate of this bug. ***

Comment 13 Sanket Jagtap 2016-12-06 13:31:04 UTC
Build : Satellite 6.2.5 snap2

Steps for verification:
1. Client with hostname and different hostname -f output 

[root@sjagtap-client ~]# hostname -f
sjagtap-client.abc.com
[root@sjagtap-client ~]# hostname
sjagtap-client

2. Registered the Client with satellite via subs-man
subscription-manager register --org="Default_Organizati
on" --activationkey="rhel7_ak"

3.Installed puppet and Katello-agent , configured puppet.conf with necessary details
certname        = sjagtap-client.abc.com


No duplicate Hosts , host was registered as sjagtap-client.abc.com

Comment 14 Bryan Kearney 2016-12-12 18:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940

Comment 15 Bryan Kearney 2016-12-12 18:48:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940


Note You need to log in before you can comment on or make changes to this bug.