Bug 1385198 - Network Manager incorrect MTU
Summary: Network Manager incorrect MTU
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 25
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Beniamino Galvani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1405545 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-15 03:27 UTC by Sergey Patsynyak
Modified: 2017-05-05 10:19 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-05 10:19:51 UTC


Attachments (Terms of Use)
[PATCH] device: properly handle MTU for devices with @iface != @ip_iface (5.30 KB, patch)
2016-10-23 18:12 UTC, Beniamino Galvani
no flags Details | Diff
[PATCH] editor: disable MTU spin button in Ethernet page for PPPoE connections (4.97 KB, patch)
2016-10-23 18:13 UTC, Beniamino Galvani
no flags Details | Diff

Description Sergey Patsynyak 2016-10-15 03:27:24 UTC
Description of problem:
The Gnome Network Manager sets incorrect MTU for my ppp0 connection when it's created. Manual MTU change under Ethernet tab does not work. MTU is set to 1500 but it should be 1492.

ifconfig output:
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
ppp0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500

How I bypass this issue:
https://ask.fedoraproject.org/en/question/94426/wrong-mtu-for-pppoe/

Version-Release number of selected component (if applicable):
1.4.2

Steps to Reproduce:
1. # nm-connection-editor
2. create a DSL connection

Actual results:
Specific sites do not respond

Comment 1 Beniamino Galvani 2016-10-23 18:12 UTC
Created attachment 1213250 [details]
[PATCH] device: properly handle MTU for devices with @iface != @ip_iface

Comment 2 Beniamino Galvani 2016-10-23 18:13 UTC
Created attachment 1213251 [details]
[PATCH] editor: disable MTU spin button in Ethernet page for PPPoE connections

Comment 3 Beniamino Galvani 2016-10-23 18:14:34 UTC
There is a regression in NM that causes an incorrect default MTU value
to be set for PPP devices; the first patch fixes it.

If you want to set a manual MTU, this is not possible at the moment
with the connection-editor GUI. The MTU property in the Ethernet page
has no effect for PPPoE connections and should be probably disabled
(patch 2). Note that the GUI doesn't support all possible properties
of a connection, but only a subset of the most common and useful ones.

You can change the PPP MTU from the command line with:

 $ nmcli connection modify <ppp-con-name> ppp.mtu 1492

Comment 4 Lubomir Rintel 2016-11-11 13:45:46 UTC
Both patches looks all right.

Comment 5 Francesco Giudici 2016-11-11 14:01:31 UTC
They both look good to me too.

Comment 7 Beniamino Galvani 2016-12-19 09:12:00 UTC
*** Bug 1405545 has been marked as a duplicate of this bug. ***

Comment 8 Sergey Patsynyak 2017-04-30 10:04:05 UTC
Hi Beniamino, unfortunately I can't test your patches. I have fedora 26 alpha and I can't connect in LiveCD (as I usually could).

[1493590794.9258] keyfile: add connection /etc/NetworkManager/system-connections/Televox (05d5da0f-c805-4992-bb0e-8f0c07f1c568,"Televox")
[1493590794.9273] audit: op="connection-add" uuid="05d5da0f-c805-4992-bb0e-8f0c07f1c568" name="Televox" pid=2537 uid=1000 result="success"
[1493590817.0509] device (enp5s0): Activation: starting connection 'Televox' (05d5da0f-c805-4992-bb0e-8f0c07f1c568)
[1493590817.0511] audit: op="connection-activate" uuid="05d5da0f-c805-4992-bb0e-8f0c07f1c568" name="Televox" pid=2590 uid=1000 result="success"
[1493590817.0514] device (enp5s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
[1493590817.0517] manager: NetworkManager state is now CONNECTING
[1493590817.0526] device (enp5s0): state change: prepare -> config (reason 'none') [40 50 0]
[1493590817.0993] device (enp5s0): state change: config -> ip-config (reason 'none') [50 70 0]
[1493590817.0996] device (enp5s0): PPPoE failed to start: the PPP plugin /usr/lib64/NetworkManager/libnm-ppp-plugin.so is not installed
[1493590817.0997] device (enp5s0): state change: ip-config -> failed (reason 'ppp-start-failed') [70 120 12]
[1493590817.1001] manager: NetworkManager state is now CONNECTED_LOCAL
[1493590817.1010] device (enp5s0): Activation: failed for connection 'Televox'
[1493590817.1041] device (enp5s0): state change: failed -> disconnected (reason 'none') [120 30 0]
[1493590817.1085] connectivity: check for uri 'http://fedoraproject.org/static/hotspot.txt' failed with 'Error resolving “fedoraproject.org”: Name or 
[1493590859.2308] policy: auto-activating connection 'Wired connection 1'
[1493590859.2329] device (enp5s0): Activation: starting connection 'Wired connection 1' (fe6b7137-2431-3781-93e9-0a7ffa8ea668)
[1493590859.2336] device (enp5s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
[1493590859.2339] manager: NetworkManager state is now CONNECTING
[1493590859.2357] device (enp5s0): state change: prepare -> config (reason 'none') [40 50 0]
[1493590859.2716] device (enp5s0): state change: config -> ip-config (reason 'none') [50 70 0]
[1493590859.2724] dhcp4 (enp5s0): activation: beginning transaction (timeout in 45 seconds)
[1493590859.2759] dhcp4 (enp5s0): dhclient started with pid 2668

I'm not sure if I should create a new thread.

Comment 9 Beniamino Galvani 2017-04-30 21:18:32 UTC
(In reply to Sergey Patsynyak from comment #8)
> Hi Beniamino, unfortunately I can't test your patches. I have fedora 26
> alpha and I can't connect in LiveCD (as I usually could).
>
> [1493590817.0996] device (enp5s0): PPPoE failed to start: the PPP plugin
> /usr/lib64/NetworkManager/libnm-ppp-plugin.so is not installed

PPP support was moved to a separate package to reduce the dependency chain of core NM package.

Thus, on F26 you need to install the NetworkManager-ppp package to use PPP/PPPoE.

Comment 10 Sergey Patsynyak 2017-05-05 10:19:51 UTC
Beniamino, both patches work perfectly. Thank you!


Note You need to log in before you can comment on or make changes to this bug.