Bug 1405545 - Fedora 24/25 NetworkManager issue with MTU on PPPoE
Summary: Fedora 24/25 NetworkManager issue with MTU on PPPoE
Keywords:
Status: CLOSED DUPLICATE of bug 1385198
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 25
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Beniamino Galvani
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-16 16:38 UTC by Bogdan
Modified: 2016-12-19 09:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-19 09:12:00 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Bogdan 2016-12-16 16:38:47 UTC
Description of problem:
Cannot adjust MTU with NetworkManager from nm-connection-editor. The change is submitted and it gets into the config file, however the MTU does not change on the interface even after reboot. The config change is permanent, it reflects in the config files, but it does not apply to the interface properly. This issue was not present in Fedora23x64. More than that, the MTU was set to automatic and the PPPoE connection was working properly with not need to change.

Version-Release number of selected component (if applicable):
Not sure - whatever Fedora24 comes with in therms of NetworkManager

How reproducible:
Either upgrade from Fedora23 to Fedora24, or do a clean install of Fedora24. If the issue has not been resolved since Fedora24, it is present across the board in NetworkManager.

Steps to Reproduce:
1. test on a PPPoE connection
2. netstat -i
3. the interface will show a MTU of 1500 even if changed to 1492 or other size. Check the config files as the MTU change will be present in the configuration.

Actual results:
PING to any website works properly as the ping packets are small. DNS will resolve as the UDP packets are small as well. No web browsing is possible as the payload is big and the packets get dropped on the ISP side. Also cannot download anything. wget will not work either. Basically nothing with big payload will go through.

Expected results:
PING to any website works properly as the ping packets are small. DNS will resolve as the UDP packets are small as well. No web browsing is possible as the payload is big and the packets get dropped on the ISP side. Also cannot download anything. wget will not work either. Basically nothing with big payload will go through.

Additional info:
only PPPoE connections seem to be affected. Normal Ethernet connections are not affected since the 1500 MTU is the de-facto standard for these links. I personally tried to change the MTU to 1492 and did not affect anything. As well, trying to change the MTU manually with ifconfig caused the remote connection to drop and the access to the machine is lost. Rebooting the machine caused the MTU configuration not to be kept and it gets back to 1500.

Comment 1 Thomas Haller 2016-12-18 16:42:07 UTC
I think this is fixed upstream by https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=00ce005e51b26603c05fae99df401127ee68348d

Looks like a duplicate of bug 1385198.

Assigning to Beniamino for confirmation.

Comment 2 Beniamino Galvani 2016-12-19 09:12:00 UTC
(In reply to Thomas Haller from comment #1)
> I think this is fixed upstream by
> https://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/
> ?id=00ce005e51b26603c05fae99df401127ee68348d
>
> Looks like a duplicate of bug 1385198.

Correct, after that commit the PPP MTU will be correctly set to the
MTU of the underlying interface minus 8 (unless overridden by the user).

Regarding the problem in manually setting the MTU from
nm-connection-editor, probably you have set it in the "Ethernet" tab,
which has no effect on the PPP interface. To prevent such confusion,
that MTU field is now disabled for PPP connections [1].

As a workaround, you should be able to manually set the PPP MTU using
nmcli:

 nmcli connection modify "Connection name" ppp.mtu 1492

[1] https://git.gnome.org/browse/network-manager-applet/commit/?id=518dde27d2a0e7f9409db069eda373390d91ff8b

*** This bug has been marked as a duplicate of bug 1385198 ***


Note You need to log in before you can comment on or make changes to this bug.