Bug 1385470 - Overcloud deployment fails: Exception updating plan: Error parsing template Template format version not found. [NEEDINFO]
Summary: Overcloud deployment fails: Exception updating plan: Error parsing template T...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Dougal Matthews
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1382450
TreeView+ depends on / blocked
 
Reported: 2016-10-17 06:40 UTC by Marius Cornea
Modified: 2016-12-14 16:20 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-common-5.3.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:20:48 UTC
pmyers: needinfo? (jcoufal)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 385471 None None None 2016-10-17 10:42:39 UTC

Description Marius Cornea 2016-10-17 06:40:05 UTC
Description of problem:
Overcloud deployment fails with the following error:

Exception updating plan: Error parsing template http://192.168.0.1:8080/v1/AUTH_99953bb093fa41a39c796e4de3666aaa/overcloud/overcloud.yaml Template format version not found.
06:33:17 Removing the current plan files

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-5.0.0-0.20161003064637.d636e3a.1.2.el7ost.noarch
openstack-tripleo-common-5.2.1-0.20161007114757.cc19d04.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates
openstack overcloud deploy --templates \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e ~/templates/network-environment.yaml \
-e $THT/environments/storage-environment.yaml \
-e ~/templates/disk-layout.yaml \
-e ~/templates/enable-tls.yaml \
-e ~/templates/inject-trust-anchor.yaml \
-e ~/templates/tls-endpoints-public-ip.yaml \
--control-scale 3 \
--control-flavor controller \
--compute-scale 1 \
--compute-flavor compute \
--ceph-storage-scale 1 \
--ceph-storage-flavor ceph \
--ntp-server clock.ntp.com 


Actual results:
Removing the current plan files
Uploading new plan files
Started Mistral Workflow. Execution ID: dec94f8e-44eb-433b-9f3d-efc2aaf3526c
Exception updating plan: Error parsing template http://192.168.0.1:8080/v1/AUTH_99953bb093fa41a39c796e4de3666aaa/overcloud/overcloud.yaml Template format version not found.


Expected results:
Deployment proceeds.

Comment 1 Michele Baldessari 2016-10-17 06:48:51 UTC
The reason is actually the previous error in the logs:
ClientException: Object GET failed: http://192.0.2.1:8080/v1/AUTH_04b2ec987c6246e6a58d17b4037e7d08/overcloud/j2_excludes.yaml

And the reson is that we are missing the following change in tripleo-common:
commit ad2edc32e343fac048e795e1cd5fc5f094084095
Author: Carlos Camacho <ccamacho@redhat.com>
Date:   Mon Oct 10 09:08:39 2016 +0200

    Default the J2 excludes files to safe values.
    
    This submission add 3 validations when the J2
    excludes file is processed.
    
    1- j2_excludes.yaml does not exist.
    2- j2_excludes.yaml its empty.
    3- j2_excludes.yaml only contains 'name:'
       without any template.
    
    The last 3 conditions will be defaulted to {"name": []}
    
    Previously the inclusion of j2_excludes.yaml was mandatory.
    
    Partial-Bug: #1626976

Comment 2 Michele Baldessari 2016-10-17 06:49:48 UTC
In my testing I updated to this rpm http://trunk.rdoproject.org/centos7-newton/current/openstack-tripleo-common-5.2.1-0.20161015221239.3163e51.el7.centos.noarch.rpm and was able to complete an OSP10 deployment

Comment 4 Jon Schlueter 2016-10-17 10:42:39 UTC
Mentioned patch was merged to stable/newton on 2016-10-13

Comment 10 errata-xmlrpc 2016-12-14 16:20:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.