Bug 1382450 - [RFE] [HA] Implement new, scalable, ops-friendly HA architecture with director integration for automatic upgrades
Summary: [RFE] [HA] Implement new, scalable, ops-friendly HA architecture with directo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Michele Baldessari
QA Contact: Tomas Jamrisko
URL:
Whiteboard:
Depends On: 1385470
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-06 17:51 UTC by Rob Young
Modified: 2016-12-14 16:10 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.1.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:10:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Rob Young 2016-10-06 17:51:22 UTC
Description of problem:

Tracking RFE for the implementation and testing of new HA NG updates, upgrades via director. This RFE is a supplement to https://bugzilla.redhat.com/show_bug.cgi?id=1336782 and should be used to track activities related to updates and upgrades to the new HA NG architecture.

Requirement:

- Provides auto upgrades from OSP 9 to 10
- Provides auto upgrades from OSP N to N+1 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michele Baldessari 2016-10-11 07:55:28 UTC
Upstream merged. All the bits landed downstream already. Any upgrade testing will actually get an HA-NG deployment at the end of the upgrade process.

Comment 4 Marian Krcmarik 2016-10-21 21:41:22 UTC
Verified - HA Sanity Automation passed on upgraded setup from RHOS9 to 10. The only problem found was Bug #1387302 which has easy workaround and submitted fix.

Comment 6 errata-xmlrpc 2016-12-14 16:10:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.