Bug 138548 - terminal emulation worse than fc2
terminal emulation worse than fc2
Status: CLOSED DUPLICATE of bug 128375
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 15:59 EST by Richard Henderson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mbox with test mail message (3.72 KB, text/plain)
2004-11-09 16:00 EST, Richard Henderson
no flags Details
output of test (670 bytes, text/plain)
2004-11-09 16:01 EST, Richard Henderson
no flags Details

  None (edit)
Description Richard Henderson 2004-11-09 15:59:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
When using mutt, the screen becomes corrupt almost instantaneously.
It looks as if the clear-to-end-of-line command is being ignored.

This is most visible with the half-page scroll operations; full-page
scroll operations appear to clear the entire screen first, and so do
not show the corruption.

Version-Release number of selected component (if applicable):
gnome-terminal-2.7.3-1

How reproducible:
Always

Steps to Reproduce:
Here I've got one gnome-terminal and one xterm open.  $TERM is set
to xterm in both.  I've opened a random message that's long enough
to scroll.  I've scrolled down a half-page (d), refreshed the screen
(^L), then scrolled up a half-page (u) and pasted the results.

Due to the wrapping that happens in the web form boxes, I'll have
to attach the output.  I'll also attach the mail message used for
the tests.

Additional info:
Comment 1 Richard Henderson 2004-11-09 16:00:13 EST
Created attachment 106373 [details]
mbox with test mail message
Comment 2 Richard Henderson 2004-11-09 16:01:01 EST
Created attachment 106374 [details]
output of test
Comment 3 Bill Nottingham 2004-11-09 16:10:50 EST
TERM=gnome mutt will solve this. See also bug 122815, bug 134300, and
bug 128375.
Comment 4 Ray Strode [halfline] 2004-11-09 16:19:12 EST
Hi Richard,

This is a duplicate of bug 128375.  You can track its progress there.

*** This bug has been marked as a duplicate of 128375 ***
Comment 5 Alejandro Gonzalez Hernandez - Imoq 2004-11-10 17:30:29 EST
 You are not authorized to access bug #128375.

Very nice ;) :P
Comment 7 Ray Strode [halfline] 2005-06-02 14:05:32 EDT
Hi guys,
It's not actually gnome-terminal's problem.  It's vte's. Check out bug 128375
for details.
Comment 8 Red Hat Bugzilla 2006-02-21 14:06:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.