Bug 138583 - system-config-soundcard gives error on startup and exits.
system-config-soundcard gives error on startup and exits.
Status: CLOSED DUPLICATE of bug 142801
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-09 19:04 EST by Michael Stevens
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 12:14:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Stevens 2004-11-09 19:04:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Upgraded a FC2 system to FC3 using the DVD ISO image.

Previously sound was working as expected. The system has via onboard
sound, and a Soundblaster Live PCI sound card.

Now, no sound is output, although programs such as xmms appear to be
playing successfully. Running system-config-soundcard gives the
following error in startup:

[root@miyazaki etc]# system-config-soundcard
/usr/share/system-config-soundcard/soundcard.py:151:
DeprecationWarning: use gtk.ComboBox
  self.primaryDeviceOptionMenu = gtk.OptionMenu()
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 159, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list

And exits.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.10-1

How reproducible:
Always

Steps to Reproduce:
Run system-config-soundcard and enter the root password.

Actual Results:  Saw Python exception as shown above. Program exited.

Expected Results:  Program would run and allow me to configure soundcards.

Additional info:

Error message again:
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 159, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list
Comment 1 Michael Stevens 2004-11-09 20:11:01 EST
I tried removing /etc/sysconfig/hwconf as suggested by someone on
fedora-list, and rerunning kudzu to redetect my hardware.

This fixed the problem with system-config-soundcard not starting, but
I still have no sound.

Now s-c-s will start, I can select "Play Test Sound" and not hear
anything, and trying to set the Primary Audio Device seems to work but
is not remembered if I exit and restart s-c-s.
Comment 2 Need Real Name 2004-11-29 16:59:59 EST
Hi, similar here:
[root@darkstar sysconfig]# system-config-soundcard
/usr/share/system-config-soundcard/soundcard.py:151:
DeprecationWarning: use gtk.ComboBox
  self.primaryDeviceOptionMenu = gtk.OptionMenu()
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 159, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list


the AUDIO entries in /etc/sysconfig/hwconf are:
-
class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "Quicknet Technologies Inc: Unknown device 0500"
vendorId: 15e2
deviceId: 0500
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  7
pcifn:  0
-
class: AUDIO
bus: PCI
detached: 0
driver: snd-intel8x0
desc: "nVidia Corporation nForce2 AC97 Audio Controler (MCP)"
vendorId: 10de
deviceId: 006a
subVendorId: 1462
subDeviceId: 5700
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  6
pcifn:  0
-
class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "nVidia Corporation nForce MultiMedia audio [Via VT82C686B]"
vendorId: 10de
deviceId: 006b
subVendorId: 1462
subDeviceId: 5700
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  5
pcifn:  0
-
class: AUDIO
bus: USB
detached: 0
driver: snd-usb-audio
desc: "Plantronics Plantronics Headset"
usbclass: 1
usbsubclass: 2
usbprotocol: 0
usbbus: 2
usblevel: 1
usbport: 0
usbdev: 2
vendorId: 047f
deviceId: 0ca1
usbmfr: Plantronics
usbprod: Plantronics Headset
-
class: AUDIO
bus: USB
detached: 0
driver: snd-usb-audio
desc: "Plantronics Plantronics Headset"
usbclass: 1
usbsubclass: 2
usbprotocol: 0
usbbus: 2
usblevel: 1
usbport: 0
usbdev: 2
vendorId: 047f
deviceId: 0ca1
usbmfr: Plantronics
usbprod: Plantronics Headset

s-c-s does not start after removing the AUDIO entries and starting
kudzu. Also I only have the Plantronics in use, but can't hear
anything, it is shown in the gnome volume control though.

I think it might have to do with the latest kernel upgrade. I now run:
2.6.9-1.681_FC3 #1 Thu Nov 18 15:10:10 EST 2004 i686 athlon i386 

I thought it worked before...

thanks,
 Florian
Comment 3 Bastien Nocera 2005-04-02 12:14:19 EST

*** This bug has been marked as a duplicate of 142801 ***

Note You need to log in before you can comment on or make changes to this bug.