Bug 142801 - system-config-soundcard broken, does not bring up gui.
system-config-soundcard broken, does not bring up gui.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bastien Nocera
:
: 138583 140176 149540 149779 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-14 04:18 EST by Erik P. Olsen
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.2.11-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 07:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik P. Olsen 2004-12-14 04:18:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
running system-config-soundcard from command line yields:
[root@epo ~]# system-config-soundcard
/usr/share/system-config-soundcard/soundcard.py:151:
DeprecationWarning: use gtk.ComboBox
  self.primaryDeviceOptionMenu = gtk.OptionMenu()
Traceback (most recent call last):
  File
"/usr/share/system-config-soundcard/system-config-soundcard.py", line
46, in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 159, in
__init__
   
self.primaryDeviceMenu.set_active(self.cardList.index(self.soundcardBackend.getDefaultCard()))
ValueError: list.index(x): x not in list

Version-Release number of selected component (if applicable):
1.2.10-1

How reproducible:
Always

Steps to Reproduce:
1.Enter root env.
2.system-config-soundcard
3.
    

Actual Results:  See description.

Expected Results:  Soundcard detection.

Additional info:
Comment 1 Marco 2005-03-25 08:13:51 EST
Same here with Fedora Core 4 test 1, please fix it.



/usr/share/system-config-soundcard/soundcard.py:75: GtkDeprecationWarning:
gtk.FALSE is deprecated, use False instead
  self.box = gtk.VBox(gtk.FALSE, 8)
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in __init__
    self.device, self.module, self.maker, self.model =
self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 106, in
getData
    maker, model = string.split(description, " ", 1)
ValueError: need more than 1 value to unpack 
Comment 2 Bastien Nocera 2005-04-02 10:01:09 EST
Marco, your crash didn't have *anything* to do with the original bug report. I
fixed it in CVS anyway.

2005-04-02  Bastien Nocera  <hadess@hadess.net>

        * src/soundcardBackend.py: If we couldn't find the default soundcard,
        it will be the first one, don't crash if the description doesn't have
        a space in it (Closes: #142801)
Comment 3 Bastien Nocera 2005-04-02 12:02:18 EST
*** Bug 149779 has been marked as a duplicate of this bug. ***
Comment 4 Bastien Nocera 2005-04-02 12:13:38 EST
*** Bug 140176 has been marked as a duplicate of this bug. ***
Comment 5 Bastien Nocera 2005-04-02 12:14:26 EST
*** Bug 138583 has been marked as a duplicate of this bug. ***
Comment 6 Bastien Nocera 2005-04-02 12:24:33 EST
*** Bug 149540 has been marked as a duplicate of this bug. ***
Comment 7 Marco 2005-04-02 13:25:52 EST
(In reply to comment #2)
> Marco, your crash didn't have *anything* to do with the original bug report. I
> fixed it in CVS anyway.
> 
> 2005-04-02  Bastien Nocera  <hadess@hadess.net>
> 
>         * src/soundcardBackend.py: If we couldn't find the default soundcard,
>         it will be the first one, don't crash if the description doesn't have
>         a space in it (Closes: #142801)

Ops, thanx anyway, very annoying bug :)
Comment 8 Marco 2005-04-29 08:40:01 EDT
(In reply to comment #2)
> Marco, your crash didn't have *anything* to do with the original bug report. I
> fixed it in CVS anyway.

Ok I have seen,
now it works, but it says:

Vendor: Creative
Model: Labs SB Audigy LS


ok I can survive :)
but teorically Labs should be after Creative.

Note You need to log in before you can comment on or make changes to this bug.