Bug 1386634 - Missing python-cmd2 dependency
Summary: Missing python-cmd2 dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cmd2
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: Upstream M2
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact:
URL:
Whiteboard:
Depends On: 1390360 1390361
Blocks: 1446155
TreeView+ depends on / blocked
 
Reported: 2016-10-19 10:40 UTC by Ondrej
Modified: 2017-05-17 19:35 UTC (History)
6 users (show)

Fixed In Version: python-cmd2-0.6.8-8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1390360 1446155 (view as bug list)
Environment:
Last Closed: 2017-05-17 19:35:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Ondrej 2016-10-19 10:40:36 UTC
Description of problem:
Customer deployed a RHEL VM on Red Hat Openstack (already installed and working). Now inside the RHEL guest, customer is willing to install the Openstack **client** tool (cmdline neutron, nova) to interact with OSP APIs.

The issue is that after installing the cmdline tools (via yum install python-openstackclient inside a container) in that RHEL guest, the tools fail to work due a missing dependecy (package "which").

The goal is to include which as a dependency for python-cmd2.

line 20:
https://github.com/openstack/cliff/blob/master/cliff/interactive.py

$ rpm -qf /usr/lib/python2.7/site-packages/openstackclient/shell.py
python-openstackclient-1.0.3-3.el7ost.noarch
$ rpm -qf /usr/lib/python2.7/site-packages/cmd2.py
python-cmd2-0.6.7-5.el7ost.noarch

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Mike Burns 2016-10-31 19:51:50 UTC
This issue is very low priority since the workaround is extremely simple (yum install which) and the chances of hitting this are remote (grub2 requires which, so almost *any* system would have the package).

Our version of python-cmd2 is a repackage of the version in the RDO community (which is in turn a repackage of the fedora version) so cloning this around for tracking in those systems.

Comment 4 Pablo Iranzo Gómez 2017-01-16 08:58:19 UTC
(In reply to Mike Burns from comment #1)
> This issue is very low priority since the workaround is extremely simple
> (yum install which) and the chances of hitting this are remote (grub2
> requires which, so almost *any* system would have the package).
> 
> Our version of python-cmd2 is a repackage of the version in the RDO
> community (which is in turn a repackage of the fedora version) so cloning
> this around for tracking in those systems.

Hi Mike,
In this case, the issue raised when the commands for managed were installed inside a container, so not really sure about the grub dependency to be satisfied there.

Even if it has a simple workaround, wouldn't it be also very simple to declare that dependency as the RPM do really require that package to be installed?

Once that's done in the .spec for OSP 7 that this bz was reported against, it should be easy to have the fix on any rpm built after it.

Comment 8 errata-xmlrpc 2017-05-17 19:35:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.