Bug 1390360 - Missing python-cmd2 dependency
Summary: Missing python-cmd2 dependency
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-cmd2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 1386634 1390361 1446155
TreeView+ depends on / blocked
 
Reported: 2016-10-31 19:52 UTC by Mike Burns
Modified: 2017-04-27 11:02 UTC (History)
11 users (show)

(edit)
Clone Of: 1386634
: 1390361 (view as bug list)
(edit)
Last Closed: 2016-11-14 20:59:59 UTC


Attachments (Terms of Use)
patch (1.14 KB, text/plain)
2016-10-31 19:57 UTC, Mike Burns
no flags Details

Description Mike Burns 2016-10-31 19:52:40 UTC
+++ This bug was initially created as a clone of Bug #1386634 +++

Description of problem:
Customer deployed a RHEL VM on Red Hat Openstack (already installed and working). Now inside the RHEL guest, customer is willing to install the Openstack **client** tool (cmdline neutron, nova) to interact with OSP APIs.

The issue is that after installing the cmdline tools (via yum install python-openstackclient inside a container) in that RHEL guest, the tools fail to work due a missing dependecy (package "which").

The goal is to include which as a dependency for python-cmd2.

line 20:
https://github.com/openstack/cliff/blob/master/cliff/interactive.py

$ rpm -qf /usr/lib/python2.7/site-packages/openstackclient/shell.py
python-openstackclient-1.0.3-3.el7ost.noarch
$ rpm -qf /usr/lib/python2.7/site-packages/cmd2.py
python-cmd2-0.6.7-5.el7ost.noarch

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Mike Burns on 2016-10-31 15:51:50 EDT ---

This issue is very low priority since the workaround is extremely simple (yum install which) and the chances of hitting this are remote (grub2 requires which, so almost *any* system would have the package).

Our version of python-cmd2 is a repackage of the version in the RDO community (which is in turn a repackage of the fedora version) so cloning this around for tracking in those systems.

Comment 1 Mike Burns 2016-10-31 19:57 UTC
Created attachment 1215898 [details]
patch

patch that resolves this issue

Comment 2 hguemar 2016-10-31 20:28:53 UTC
I fixed it as provenpackager (FAS: hguemar) since the issue is obvious and also affecting cliff. I made a small change to the patch submitted by Mike, by requiring the binary instead of the package.
I'll let maintainers backport the patch to F25 and earlier.

Comment 3 Ralph Bean 2016-11-01 20:38:06 UTC
Thanks Haikel!

Comment 4 Fedora Update System 2016-11-01 20:52:04 UTC
python-cmd2-0.6.8-8.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f55b8b9eac

Comment 5 Fedora Update System 2016-11-01 20:52:13 UTC
python-cmd2-0.6.8-8.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-31e439eda5

Comment 6 Fedora Update System 2016-11-01 20:52:22 UTC
python-cmd2-0.6.8-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-279733673b

Comment 7 Fedora Update System 2016-11-02 14:52:19 UTC
python-cmd2-0.6.8-8.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f55b8b9eac

Comment 8 Fedora Update System 2016-11-05 03:31:32 UTC
python-cmd2-0.6.8-8.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-31e439eda5

Comment 9 Fedora Update System 2016-11-05 03:53:17 UTC
python-cmd2-0.6.8-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-279733673b

Comment 10 Fedora Update System 2016-11-06 01:51:46 UTC
python-cmd2-0.6.8-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-279733673b

Comment 11 Fedora Update System 2016-11-14 20:59:59 UTC
python-cmd2-0.6.8-8.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-11-14 23:51:21 UTC
python-cmd2-0.6.8-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-11-19 21:07:41 UTC
python-cmd2-0.6.8-8.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.