This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 13882 - alt/meta shortcut confusion
alt/meta shortcut confusion
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Florence gold
:
: 24124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 03:11 EDT by Brian Ryner
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 18:07:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to fix it. (1.86 KB, patch)
2001-03-09 18:07 EST, Trond Eivind Glomsrxd
no flags Details | Diff

  None (edit)
Description Brian Ryner 2000-07-13 03:11:30 EDT
The default sawmill keybindings assume that the user's Alt key will be
mapped to Meta.  This is not always the case, however, as I found out after
changing my keyboard mapping to pc104.  I would suggest either making sure
alt is always defined one way, or add Alt keybindings so that it will work
either way.
Comment 1 Havoc Pennington 2000-07-17 13:06:57 EDT
Matt, should PC104 map meta to alt?
Comment 2 John Cagle 2000-07-24 17:53:02 EDT
This is still happening in beta4.  I have a Compaq DeskPro EN SFF where
the meta key ends up being the "Windows" key, not ALT.  I suggest always
mapping meta to ALT.
Comment 3 Havoc Pennington 2000-08-06 00:56:47 EDT
I think we decided this was a default keymap issue, i.e. not a sawfish bug, 
please change the component back if that's not the case
Comment 4 Matt Wilson 2000-08-06 01:01:47 EDT
pc105 is broken, I've move it to pc101 until xfree is fixed.
Comment 5 Havoc Pennington 2000-08-09 19:48:19 EDT
Assigning to the XFree owner
Comment 6 Glen Foster 2000-08-16 14:11:39 EDT
This defect is considered MUST-FIX for Winston Gold release
Comment 7 John Cagle 2000-08-16 14:15:22 EDT
BTW, RC1 is working for me on the DeskPro EN/SFF.
Comment 8 Matt Wilson 2000-08-16 14:50:25 EDT
pc104 is broken.  Use pc101 (which is what all our tools write out now.)  The
XFree people know about our issues with the pc104 map and it's currently an
upstream problem now.
Comment 9 Preston Brown 2001-03-06 12:08:38 EST
*** Bug 24124 has been marked as a duplicate of this bug. ***
Comment 10 Trond Eivind Glomsrxd 2001-03-06 12:49:53 EST
Left Alt in both cases return keycode 64 (Alt_L), it seems to be treated
differently by some applications.
Comment 11 Brian Ryner 2001-03-06 14:52:16 EST
This is only a default keymap issue if the Alt key is interpreted as Meta on the
pc101 keymap.  The fact remains that the sawfish bindings are looking for Meta.
Comment 12 Brian Ryner 2001-03-06 16:39:53 EST
Ok, this works for me on RC2 if I choose pc101.
Comment 13 Trond Eivind Glomsrxd 2001-03-06 19:09:57 EST
If you choose 104/105 (as opposed to 101/102), you IMHO indicate that you want
to take advantage of them and use alt as alt and windows-key as meta.

The file /usr/X11R6/lib/X11/xkb/symbols/pc104 looks like it could be changed, I
didn't get any effect out of it though.
Comment 14 Trond Eivind Glomsrxd 2001-03-08 14:46:51 EST
Change the indented (">") to the nonidented in /usr/X11R6/lib/X11/xkb/symbols/us

Reassigning to mharris for inclusion in XFree.

>
> // definition for the extra keys on 104-key "Windows95" keyboards
> xkb_symbols "pc104" {
>     include "us(generic101)"
>     key <LALT> {        [       Alt_L           ]       };
>     key <RALT> {        [       Alt_R           ]       };
>     key <LWIN> {        [       Meta_L          ]       };
>     key <RWIN> {        [       Meta_R          ]       };
>     key <MENU> {        [       Menu            ]       };
>
>     // modifier mappings
>     modifier_map Mod1   { Alt_L, Alt_R };
>     modifier_map Mod4   { Meta_L, Meta_R };
> };

To make this usable on most keyboards, I suggest:

    key <LALT> {        [       Alt_L, Meta_L   ]       };
    key <RALT> {        [       Alt_R, Meta_R   ]       };
    key <LWIN> {        [       Super_L         ]       };
    key <RWIN> {        [       Super_R         ]       };
    key <MENU> {        [       Menu            ]       };

    // modifier mappings
    modifier_map Mod1   { Alt_L, Alt_R, Meta_L, Meta_R };
    modifier_map Mod4   { Super_L, Super_R };
};

Comment 15 Trond Eivind Glomsrxd 2001-03-09 18:07:33 EST
Created attachment 12263 [details]
patch to fix it.
Comment 16 Mike A. Harris 2001-03-09 23:20:03 EST
This will appear in the first 4.0.2a package released in rawhide, or whatever
the next XFree86 package becomes.

Note You need to log in before you can comment on or make changes to this bug.