Bug 24124 - Alt/meta inconsistency
Alt/meta inconsistency
Status: CLOSED DUPLICATE of bug 13882
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-16 13:05 EST by Brian Ryner
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-25 10:46:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2001-01-16 13:05:35 EST
X seems to be recognizing my Alt keys as Alt, but sawfish is configured to
use Meta for all of its shortcuts.

I chose the "Standard 105-key" keyboard (not sure of the exact wording),
which was the default choice during the install.
Comment 1 David Mason 2001-01-16 14:02:20 EST
If you open up the GNOME Control Center you will see an entry under Sawfish
Window Manager that says shortcuts. In this dialog you can change *any* sawfish
keybinding to whatever you wish. When you edit or add a new keybinding you can
even 'grab' the key by pressing the 'Grab' button and pressing the desired key.
Comment 2 Brian Ryner 2001-01-18 18:31:43 EST
I'm aware of how to change sawfish keybindings.

The bug is that the default bindings are configured to use Meta, which most
users will not have on their keyboard.  Either the default bindings should
change to Alt (my suggestion), or X should be configured to treat Alt as Meta.

Comment 3 David Mason 2001-01-18 18:44:27 EST
OK - just making sure you didn't have any over-rides in yoru configuration. We
skip the new 'W' key setup in sawfish and hardcode it to meta - will reassign to
X for binding issue. This is a problem with X setting 105 key keyboards to use
the 'Windows' key. mharris, we need to swap the windows key meta to the alt key.
Comment 4 Brian Ryner 2001-02-25 10:46:08 EST
There are still problems with this in Wolverine.  During install, I accepted the
default choice of 105-key keyboard.  Most of the shortcut keys in Sawfish do not
work, because they are configured for Meta, but my Alt key is interpreted as
Alt, not Meta.

This needs fixed, either by changing the default Sawfish bindings to use Alt, or
causing Alt to be mapped to Meta.  Bottom line is that selecting the default
keyboard during the install should give you something that is configured
correctly for most keyboards, which it doesn't seem to.
Comment 5 Preston Brown 2001-03-06 12:08:43 EST

*** This bug has been marked as a duplicate of 13882 ***

Note You need to log in before you can comment on or make changes to this bug.