Bug 138955 - [gimlet] unable to remove all entries language menu
[gimlet] unable to remove all entries language menu
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
: 138956 (view as bug list)
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-11-11 23:14 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 10:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-11-11 23:14:20 EST
Description of problem:
There are times when user do not wish to have the LE turned on so that
an En document can be written. However, sometimes accident does happen
and ctrl-space is pressed and this cause the LE to be activated. 

So what I did was removing all the entries in GIMLET in hope that with
no LE entries, even when the activation keys are pressed, no LE will
be active. However, this is not the case.

Version-Release number of selected component (if applicable):
im-sdk-12.1-4 (FC3 Stable)

How reproducible:
Always

Steps to Reproduce:
1.log in as normal user at gdm into any of the CJK locale
2.start gedit
3.click on GIMLET and remove all entries
4.ctrl-space
  
Actual results:
LE for the locale gets activated

Expected results:
no LE available

Additional info:
I tried to select ASCII as well. But it does not seems to help.
Comment 1 Lawrence Lim 2004-11-15 00:02:51 EST
*** Bug 138956 has been marked as a duplicate of this bug. ***
Comment 2 Jens Petersen 2004-11-15 03:33:23 EST
Not sure that one ever really wants to remove *all* languages from
gimlet's menu... just all except one perhaps.

Currently what happens after you remove all langs from the lang menu,
is that when an iiimf app gets focus again the lang of the current
LE in use will get added back to gimlet.

Certainly you can add Latin to the gimlet lang list with the lang
menu editor, switch all your apps to Latin (En) and then remove
all other langs from the menu with the editor to get only the dummy
default LE in the menu.

I guess this is slightly related to bug 136991.

What behaviour would you like to see instead of the current one?
since I don't think with current iiimf that gimlet can force
iiimf off on all apps.
Comment 4 Jens Petersen 2005-05-16 10:57:50 EDT
Actually with iiimf-12.2, I seem able to remove all entries
from the gimlet menu.

But reading again carefully I thinking you're saying that
you object to iiimf still be activated by iiimgcf say after
removing all languages from gimlet's menu: agreed this is
counter intuitive but gimlet is not yet that closely
integrated with iiimf clients so this is not possible.

Note You need to log in before you can comment on or make changes to this bug.