Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
*virt-who* now reads the 'address' field provided by RHEVM to discover and report the correct host name
Previously, if the *virt-who* utility reported on a Red Hat Virtualization (RHV) host and the "hypervisor_id=hostname" option was used, *virt-who* displayed an incorrect host name value. This update ensures that *virt-who* reads the correct field value in the described circumstances and as a result, the proper host name is displayed.
DescriptionFrancisco Garcia
2016-10-28 10:44:32 UTC
Description of problem:
virt-who is using the 'name' field of the RHEV-produced xml inventory. Since that is a user-definable field, it causes issues when reporting back to Satellite 6.2 . Satellite 6.2 introduces strict hostname verification and then a FQDN should be provided by virt-who, as well as filter out underscore characters "_" .
Version-Release number of selected component (if applicable):
virt-who 0.17-9.el7sat
How reproducible:
Always, as follows
Steps to Reproduce:
1. Add a RHEV hypervisor and set their name to "my_host_name".
2. Verify that virt-who uses that field instead of "address" XML field
3. Verify that virt-who fails to report to Satellite 6.2 as "my_host_name" fails strict validation.
Actual results:
virt-who
Expected results:
virt-who should report the 'address' field, which contains the DNS hostname of the hypervisor.
Additional info:
virt-who can be easily fixed by ammending the /usr/lib/python2.7/site-packages/virtwho/virt/rhevm/rhevm.py :
146 elif self.config.hypervisor_id == 'hostname':
147 host_id = host.find('address').text
...
168 hosts[id] = virt.Hypervisor(hypervisorId=host_id, name=host.find('address').text, facts=facts)
hi Kevin,
Just checked this is valid for 3.5 to 4.1. I'd say this is also valid in all RHEV 3.x series and given it'll EOL in September, we're won't be introducing any breaking change.
Is there anything else required to fix this?
Thanks!
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHEA-2018:0895
Description of problem: virt-who is using the 'name' field of the RHEV-produced xml inventory. Since that is a user-definable field, it causes issues when reporting back to Satellite 6.2 . Satellite 6.2 introduces strict hostname verification and then a FQDN should be provided by virt-who, as well as filter out underscore characters "_" . Version-Release number of selected component (if applicable): virt-who 0.17-9.el7sat How reproducible: Always, as follows Steps to Reproduce: 1. Add a RHEV hypervisor and set their name to "my_host_name". 2. Verify that virt-who uses that field instead of "address" XML field 3. Verify that virt-who fails to report to Satellite 6.2 as "my_host_name" fails strict validation. Actual results: virt-who Expected results: virt-who should report the 'address' field, which contains the DNS hostname of the hypervisor. Additional info: virt-who can be easily fixed by ammending the /usr/lib/python2.7/site-packages/virtwho/virt/rhevm/rhevm.py : 146 elif self.config.hypervisor_id == 'hostname': 147 host_id = host.find('address').text ... 168 hosts[id] = virt.Hypervisor(hypervisorId=host_id, name=host.find('address').text, facts=facts)