Bug 1390018 - [abrt] xorg-x11-server-Xwayland: Segmentation fault in glamor callbacks
Summary: [abrt] xorg-x11-server-Xwayland: Segmentation fault in glamor callbacks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:53b3dfa24574f4dc5620e150e0e...
: 1385333 1385334 1386354 1388684 1389493 1389494 1391252 1391578 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-30 20:51 UTC by Diogo Campos
Modified: 2017-11-20 08:14 UTC (History)
7 users (show)

Fixed In Version: xorg-x11-server-1.19.0-0.7.rc2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 21:10:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (468 bytes, text/plain)
2016-10-30 20:51 UTC, Diogo Campos
no flags Details
File: dmesg (53.98 KB, text/plain)
2016-10-30 20:51 UTC, Diogo Campos
no flags Details
File: dso_list (249 bytes, text/plain)
2016-10-30 20:51 UTC, Diogo Campos
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (331 bytes, application/octet-stream)
2016-10-30 20:51 UTC, Diogo Campos
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.71 KB, application/octet-stream)
2016-10-30 20:51 UTC, Diogo Campos
no flags Details

Description Diogo Campos 2016-10-30 20:51:12 UTC
Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/bin/Xwayland
kernel:         4.8.4-301.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       unknown
type:           xorg
uid:            0

Truncated backtrace:
0: ? (?+0xf4dd8801) [0xffff8003f5367ba1]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f53da5325bf]
2: /usr/bin/Xwayland (?+0x0) [0x445d60]
3: /usr/bin/Xwayland (?+0x0) [0x42a630]
4: /usr/bin/Xwayland (?+0x0) [0x45fc90]
5: /usr/bin/Xwayland (?+0x0) [0x4ecda0]
6: /usr/bin/Xwayland (?+0x0) [0x4f0e30]
7: /usr/bin/Xwayland (?+0x0) [0x559090]
8: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f53da17b401]
9: /usr/bin/Xwayland (?+0xf1) [0x423b91]
10: ? (?+0xf1) [0xf1]

Comment 1 Diogo Campos 2016-10-30 20:51:15 UTC
Created attachment 1215615 [details]
File: backtrace

Comment 2 Diogo Campos 2016-10-30 20:51:18 UTC
Created attachment 1215616 [details]
File: dmesg

Comment 3 Diogo Campos 2016-10-30 20:51:19 UTC
Created attachment 1215617 [details]
File: dso_list

Comment 4 Diogo Campos 2016-10-30 20:51:21 UTC
Created attachment 1215618 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 5 Diogo Campos 2016-10-30 20:51:22 UTC
Created attachment 1215619 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 6 Olivier Fourdan 2016-11-02 09:18:18 UTC
That one seems to point toward glamor, any particular application running or action you were doing when the crash occurs?

$ addr2line -fe /usr/lib/debug/usr/bin/Xwayland.debug 0x445d60 0x42a630 0x45fc90 0x4ecda0 0x4f0e30 0x559090 
glamor_create_fbo_array() in /usr/src/debug/xorg-server-20161026/glamor/glamor_fbo.c:189
glamor_egl_get_display() in /usr/src/debug/xorg-server-20161026/hw/xwayland/../../glamor/glamor_egl.h:69
fbSolidBoxClipped() in /usr/src/debug/xorg-server-20161026/fb/fbfill.c:227
ProcRenderAddGlyphs() in /usr/src/debug/xorg-server-20161026/render/render.c:1091
sproc_dri3_pixmap_from_buffer() in /usr/src/debug/xorg-server-20161026/dri3/dri3_request.c:350
doPolyText() in /usr/src/debug/xorg-server-20161026/dix/dixfonts.c:1198

Comment 7 Olivier Fourdan 2016-11-02 13:20:37 UTC
Hi, in https://bugzilla.redhat.com/show_bug.cgi?id=1361712#c8 you mentioned that you did not actually use Wayland, so I wonder how/why Xwayland would crash in that case.

Is it still the case, do you still use Xorg and not Wayland? If so, how did you disable Wayland?

Comment 8 Diogo Campos 2016-11-02 20:53:38 UTC
(In reply to Olivier Fourdan from comment #7)
> Hi, in https://bugzilla.redhat.com/show_bug.cgi?id=1361712#c8 you mentioned
> that you did not actually use Wayland, so I wonder how/why Xwayland would
> crash in that case.
> 
> Is it still the case, do you still use Xorg and not Wayland? If so, how did
> you disable Wayland?

I think I could reproduce it (and give more info) here:

https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c6
https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c7
https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c8

Comment 9 Diogo Campos 2016-11-02 21:24:00 UTC
(In reply to Diogo Campos from comment #8)
> I think I could reproduce it (and give more info) here:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c6
> https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c7
> https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c8


...and, also, the same kind of crash (and the same kind of info) in a Wayland session:

https://bugzilla.redhat.com/show_bug.cgi?id=1391252

Note that:
- There are 2 xwayland processes in a Wayland session.
- The output of 'glxinfo' in a Wayland session is substantially different than the one from a X session.

Comment 10 Diogo Campos 2016-11-02 22:33:59 UTC
Another info:

If I uninstall 'xorg-x11-drv-intel'[1] I can't login in a X session anymore (Wayland session seems not affected at all).

[1] First note at: https://wiki.archlinux.org/index.php/Intel_graphics

Comment 11 Olivier Fourdan 2016-11-03 08:24:07 UTC
Ohhh... Now it makes perfect sense!

From https://bugzilla.redhat.com/show_bug.cgi?id=1389493#c9

> glamor: EGL version 1.4 (DRI2):
> Failed to initialize glamor
> Failed to initialize glamor, falling back to sw

So we get to glamor_init, set the screen->CloseScreen to glamor_close_screen() and screen->DestroyPixmap to glamor_destroy_pixmap but fail *after*, so we don't have glamor set up but still have the CloseScreen and the DestroyPixmap set to  set to the glamor routines, which explains why it crashes in either code path.

Comment 12 Olivier Fourdan 2016-11-03 09:01:53 UTC
https://patchwork.freedesktop.org/patch/119782/

Comment 13 Hans de Goede 2016-11-03 16:10:50 UTC
*** Bug 1389493 has been marked as a duplicate of this bug. ***

Comment 14 Hans de Goede 2016-11-03 16:11:06 UTC
*** Bug 1391252 has been marked as a duplicate of this bug. ***

Comment 15 Hans de Goede 2016-11-03 16:14:37 UTC
*** Bug 1385333 has been marked as a duplicate of this bug. ***

Comment 16 Hans de Goede 2016-11-03 16:14:48 UTC
*** Bug 1385334 has been marked as a duplicate of this bug. ***

Comment 17 Hans de Goede 2016-11-03 16:16:45 UTC
*** Bug 1386354 has been marked as a duplicate of this bug. ***

Comment 18 Hans de Goede 2016-11-03 16:22:07 UTC
*** Bug 1388684 has been marked as a duplicate of this bug. ***

Comment 19 Hans de Goede 2016-11-03 16:25:52 UTC
*** Bug 1389494 has been marked as a duplicate of this bug. ***

Comment 20 Hans de Goede 2016-11-03 16:31:16 UTC
*** Bug 1391578 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2016-11-03 17:22:50 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-662f51a695

Comment 22 Fedora Update System 2016-11-05 18:59:11 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-662f51a695

Comment 23 Fedora Update System 2016-11-19 21:10:20 UTC
xorg-x11-server-1.19.0-0.7.rc2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 robert fairbrother 2017-09-14 09:22:22 UTC
Description of problem:
a newly installed and updated computer with fedora on 2 high performance usb sticks

Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25

Additional info:
reporter:       libreport-2.8.0
dso_list:       /usr/bin/Xwayland xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25.i686 (Fedora Project) 1479245578
executable:     /usr/bin/Xwayland
kernel:         4.8.6-300.fc25.i686+PAE
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       5 3
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x136) [0x81f8f96]
1: ? (?+0x136) [0xb77bbe51]
2: /usr/bin/Xwayland (glamor_pixmap_exchange_fbos+0xc6d) [0x808b78d]
3: /usr/bin/Xwayland (glamor_close_screen+0x5b) [0x806cddb]
4: /usr/bin/Xwayland (fbSolid+0xdbb) [0x80a791b]

Comment 25 robert fairbrother 2017-11-19 05:35:37 UTC
Description of problem:
fresh install brand new hardware

Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/bin/Xwayland
kernel:         4.8.6-300.fc25.i686+PAE
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       unknown
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x136) [0x81f8f96]
1: ? (?+0x136) [0xb7726e51]
2: /usr/bin/Xwayland (glamor_pixmap_exchange_fbos+0xc6d) [0x808b78d]
3: /usr/bin/Xwayland (glamor_close_screen+0x5b) [0x806cddb]
4: /usr/bin/Xwayland (fbSolid+0xdbb) [0x80a791b]
5: /usr/bin/Xwayland (AddTraps+0x818e) [0x814effe]
6: /usr/bin/Xwayland (present_register_complete_notify+0x737) [0x814be27]
7: /usr/bin/Xwayland (InitFonts+0x5d5) [0x81bdf85]
8: /usr/bin/Xwayland (_init+0x5913) [0x806a3a3]
9: /lib/libc.so.6 (__libc_start_main+0xf6) [0xb6f371c6]
10: /usr/bin/Xwayland (_start+0x21) [0x8064b06]

Comment 26 Olivier Fourdan 2017-11-20 08:14:25 UTC
(In reply to robert fairbrother from comment #25)
> Description of problem:
> fresh install brand new hardware
> 
> Version-Release number of selected component:
> xorg-x11-server-Xwayland-1.19.0-0.3.20161026.fc25

This version doesn't contain the fix.


Note You need to log in before you can comment on or make changes to this bug.