Bug 139005 - Freeze on switching workspaces, Radeon Mobility M9, xinerama and accel
Freeze on switching workspaces, Radeon Mobility M9, xinerama and accel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 09:42 EST by James Dunlop
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 10:58:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xinerama xorg.conf (4.64 KB, text/plain)
2004-12-03 12:33 EST, rohirrim
no flags Details

  None (edit)
Description James Dunlop 2004-11-12 09:42:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I have a Mobility M9 (dell latitude D600).
(--) Chipset ATI Radeon Mobility 9000 (M9) Lf (AGP) found

When running xinerama, a ctrl-alt-f1 to switch to 
the console causes the system to freeze.  
I think the system remains accessible from the outside at this point.

When I use "NoAccel", the problem goes away, but
that's not something I want to do.

Didn't happen with FC2.
                             --Jamie


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12

How reproducible:
Always

Steps to Reproduce:
1. Set up xinerama for radeon
2. Try to switch to virtual console (Ctrl-Alt-F1)
3.
    

Actual Results:  Freeze of display

Additional info:
Comment 1 Sitsofe Wheeler 2004-12-02 05:17:59 EST
This could be related to bug 139005 or bug 141500
Comment 2 Sitsofe Wheeler 2004-12-02 05:19:09 EST
Oops, 139005 should have been bug 139260
Comment 3 rohirrim 2004-12-03 12:33:00 EST
Created attachment 107847 [details]
My xinerama xorg.conf
Comment 4 rohirrim 2004-12-03 12:33:19 EST
Hi,

I get the exact same problem, when running on xinerama on an ATI
Radeon Mobility M6
(01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M6 LY (prog-if 00 [VGA])
        Subsystem: IBM: Unknown device 052f
        Flags: bus master, stepping, fast Back2Back, 66Mhz, medium
devsel, latency 66, IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
according to lspci -v
), on an IBM x31 laptop, when using xinerama or mergedfb. Problem goes
away on a single screen.

The x.org or kernel updates have not helped (I'm currently running
xorg-x11-6.8.1-12.FC3.21 and kernel-2.6.9-1.681_FC3.

The system does not hang, but the display (on the X screen), keyboard
and mouse freeze. It still responds to ACPI events, as pressing the
power button executes shutdown -h properly, and the machine eventually
shuts down.

This problem did not occur in FC2.

Thanks,

Stefanos
Comment 5 rohirrim 2004-12-06 06:52:21 EST
Just to add to this, exiting the x-server or killing it, on runlevel
3, does drop you back to console, without any problems. It's just when
switching from X to console and X is running...
Comment 6 Christian Leber 2004-12-06 16:22:23 EST
To add something else:
I have the same problem with recent xorg and another distribution, and
when i killed -9 the Xorg server the box went to standby and when i
switched it on again X worked again. (namely it was ubuntu)

So it's at least not FC3 specific.
Comment 7 James Dunlop 2004-12-22 10:09:58 EST
This is fixed in the rawhide version of xorg-x11, 6.8.1.901
Comment 8 Mike A. Harris 2004-12-22 10:58:25 EST
Great to hear!  Thanks for the feedback.  We'll be releasing 6.8.2
for FC3 in the near future, as well as in rawhide.

Thanks again.

Setting status to "RAWHIDE"
Comment 9 Terry Griffin 2005-02-22 15:43:43 EST
So where's that 6.8.2 in the "near future?" I'm seeing this problem
as well with a Radeon 7500. Had to fall back to FC2 because I just
can't stop myself from pressing Ctrl-Alt-F1.

Note You need to log in before you can comment on or make changes to this bug.