Bug 139015 - Downloaded files AWOL
Downloaded files AWOL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 143129 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 10:13 EST by Owen Taylor
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 04:28:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2004-11-12 10:13:39 EST
Firefox has the policy of not asking where to save files (*). So,
where is it saving them? When I bring the Download manager, it says
"All files downloaded to Desktop" (**)

But the files aren't there. Rather, they were saved to my homedir,
I eventually figured out.

(*) The GtkFileChooser UI for save is meant to make it very easy 
and clear to save in standard locations, and I'm not sure bypassing 
it is a win. But that's not the point of this bug report.

(**) Why does the "Desktop" combobox only look like a combo on
prelight? Not clear. But not part of this bug report.
Comment 1 Owen Taylor 2004-11-12 10:16:11 EST
BTW, this is both with the fc3-final version of Firefox, and with
1.0-2.fc3.
Comment 2 Christopher Aillon 2004-11-14 15:29:22 EST
Yeah...  do we want to fix firefox to actually download to the Desktop?  Or to
say Home?  The former would probably be better with the localizers at this point.
Comment 3 Owen Taylor 2004-11-15 13:52:12 EST
If the default is going to be not to ask, I think Desktop is a much 
more  reasonable default location than the home directory. Files
downloaded to the desktop are more or less immediately visible, 
many users may  never look at their homedir at all.

(presumably it says Desktop because it downloads to the desktop
on windows?)
Comment 5 Christopher Aillon 2004-12-20 17:39:42 EST
*** Bug 143129 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Aillon 2004-12-20 17:40:41 EST
This got fixed already in rawhide last week.  It is in my queue of patches to
add to fc3, in the next update.
Comment 7 Christopher Aillon 2005-03-31 04:28:23 EST
Fixed in rawhide and fc3 updates.

Note You need to log in before you can comment on or make changes to this bug.