Bug 139032 - OO Writer crashes when enabling automatic hyphenation in Polish document
OO Writer crashes when enabling automatic hyphenation in Polish document
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
: 148948 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 12:00 EST by Michal Piotrowski
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 06:27:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This file should hang OO Writer (5.44 KB, application/octet-stream)
2004-11-12 12:15 EST, Michal Piotrowski
no flags Details

  None (edit)
Description Michal Piotrowski 2004-11-12 12:00:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When you are editing Polish document and automatic hyphenation is
enabled OO Writers hangs. It consumes 100% CPU time and the only way
to stop it is to kill it.

Version-Release number of selected component (if applicable):
1.1.2-11.5.fc3

How reproducible:
Always

Steps to Reproduce:
Method 1.
1. Set document language to Polish.
2. Set Format->Paragraph->Text Flow Hyphenation to Automatically
3. Write some text. When you reach end of the line and there is word
to hyphenate OO Writer will hang.

Method 2.
1. Open document saved in previous version where language was set to
Polish and automatic hyphenation was enabled.

Actual Results:  OO Writer hangs.

Expected Results:  OO Writer should hyphenate words.

Additional info:
Comment 1 Michal Piotrowski 2004-11-12 12:15:11 EST
Created attachment 106588 [details]
This file should hang OO Writer

This is a sample file created in Windows OO Writer with enabled hyphenation. It
crashes OO in FC.
Comment 2 Caolan McNamara 2004-11-15 07:50:51 EST
If you wait (a very long time) it will react again, its taking an
awesomely long time on first time processing of the polish hyphenation
dictionary
Comment 3 Caolan McNamara 2004-11-15 08:03:44 EST
Upstream as http://www.openoffice.org/issues/show_bug.cgi?id=37171
Comment 4 Michal Piotrowski 2004-11-16 03:49:29 EST
I waited very long time and the doucument showed up. But none of the
words were hyphenated but some of them should be hyphenated.
Comment 5 Fabrice FRANCOIS 2004-11-16 15:57:29 EST
I had the same issue and I managed to fix it. The dictionaries
installed with ooo are too numerous. I erased the superfluous
dictionaries in /usr/lib/ooo-1.1/share/dict/ooo/ and I have no more
problem now.

Fabrice.
Comment 6 Michal Piotrowski 2004-11-18 04:28:53 EST
I commented out in dictionary.lst all dictionaries and hyphenation but
Polish and English and it didn't helped.
Comment 7 Michal Piotrowski 2005-01-28 04:34:05 EST
I have updated to OpenOffice version 1.1.3-2.5.fc3 and this bug is
still here. :-(

I use also OO on Windows (OO version 1.1.3), and there this bug
doesn't occur. Hyphenation dictionaries are the same on my Linux and
Windows system.
Comment 8 Leszek Matok 2005-03-02 14:03:10 EST
This bug is still present in openoffice.org-1.1.3-6.5.0.fc3

I run gdb on the "hung" process and it's stuck in:

#0  0x06543eaf in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libhyphen645li.so
#1  0x0654440e in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libhyphen645li.so
#2  0x065408aa in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libhyphen645li.so
#3  0x043275e4 in HyphenatorDispatcher::hyphenate ()
   from /usr/lib/ooo-1.1/program/liblng645li.so
#4  0xb5a985d9 in HyphDummy_Impl::hyphenate ()
   from /usr/lib/ooo-1.1/program/libsvx645li.so
#5  0x0249d4c2 in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libi18npool645li.so
#6  0x0249819c in component_getFactory ()
   from /usr/lib/ooo-1.1/program/libi18npool645li.so
#7  0xb3c70965 in ?? () from /usr/lib/ooo-1.1/program/libsw645li.so
#8  0xbfe03d20 in ?? ()
#9  0x01ee6418 in ?? ()
#10 0xbfe03d10 in ?? ()
#11 0x00000059 in ?? ()
#12 0xbfe03d30 in ?? ()
#13 0x00000000 in ?? ()

Other 3 threads are in _dl_sysinfo_int80.
It works again after a really long time, but doesn't hyphenate, as reporter stated.
Comment 9 Leszek Matok 2005-03-02 14:19:24 EST
I discovered bug #148948 which seems to be duplicate of this one and found
resolution there! In /usr/lib/ooo-1.1/share/dict/ooo/dictionary.lst I replaced
"HYPH pl PL pl_PL" with "HYPH pl PL hyph_pl_PL" and not only it doesn't hang, it
started to hyphenate (not like I want it to, but I guess that's just a matter of
tuning the values in "Text Flow Hyphenation")! Hope that helps :)
Comment 10 Dan Williams 2005-03-02 17:09:14 EST
*** Bug 148948 has been marked as a duplicate of this bug. ***
Comment 11 Dan Williams 2005-03-03 22:45:48 EST
dcbw->cmc: fix should be included in next FC3 update, which is waiting on the U1
stuff before it goes out.
Comment 12 Dan Williams 2005-03-07 01:03:53 EST
Fixed in:

RHEL3: 1.1.2-22.2.2.EL3
RHEL4: 1.1.2-22.6.EL4
FC2: 1.1.3-9.4.0.fc3
FC3: 1.1.3-9.5.0.fc3

dcbw->cmc: Did this fix get included in devel: 1.9.82-1?
Comment 13 Caolan McNamara 2005-03-21 06:27:34 EST
No hang and correct hyphenation dictionary name in 1.9.84-1

Note You need to log in before you can comment on or make changes to this bug.