Bug 139077 - Add yum metadata to DVD iso images
Add yum metadata to DVD iso images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
: FutureFeature
: 134052 151432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 15:24 EST by Phil Schaffner
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-18 21:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Schaffner 2004-11-12 15:24:58 EST
Description of problem:
Consider adding yum metadata (createrepo, and perhaps yum-arch - for
FC2 updates) to the DVD iso.  The image (or for that matter the
physical media) could then be mounted  as a local yum [os] repo,
accessed as a file:/ URL.  Would save user's disk space and
everybody's network bandwidth.


Version-Release number of selected component (if applicable):
FC4 DVD iso image

How reproducible:
Always

Steps to Reproduce:
1. Mount DVD
2. Specify as yum [os] repo
3. yum install somepackage
  
Actual results:
Fails due to lack of metadata.

Expected results:
Could run yum install of new packages from local image.

Additional info:
Comment 1 Elliot Lee 2004-11-15 16:59:34 EST
Not likely to happen anytime soon, but I'll keep it on the TODO list.
Comment 2 Elliot Lee 2004-12-03 14:18:52 EST
*** Bug 134052 has been marked as a duplicate of this bug. ***
Comment 3 Terrel Shumway 2005-02-25 14:32:06 EST
workaround:
mount the image
create a new directory for the local repo: 
  mkdir myrepo
  cd myrepo
create symlinks to all of the rpms
  find /media/dvd -name '*.rpm' >allrpms
  cat allrpms |(for x in read; do ln -s $x $(basename $x);done) 
create the repodata
  createrepo .
Comment 4 Elliot Lee 2005-04-26 15:00:16 EDT
*** Bug 151432 has been marked as a duplicate of this bug. ***
Comment 5 Ville Skyttä 2005-04-26 15:23:40 EDT
I'd like to add that making the repodata comps enabled would be a nice bonus.
Comment 6 Matthias Saou 2006-02-16 08:16:34 EST
Update : in FC5 test releases, "repodata" is present on the DVDs AFAICS...
Comment 7 Phil Schaffner 2006-02-18 21:33:25 EST
So - haven't been following closely of late.  Looks like resolution RAWHIDE
should get this one off the books.

Note You need to log in before you can comment on or make changes to this bug.